aboutsummaryrefslogtreecommitdiffstats
path: root/print/latex-subfloat/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-29 18:48:17 +0800
committerkrion <krion@FreeBSD.org>2004-01-29 18:48:17 +0800
commit94eaefe6cdc7fc3a273e2f46dd70e8fea8581704 (patch)
treec18a14db9c548404ede7aba5a69785c73cfeb7c0 /print/latex-subfloat/Makefile
parent12dbfeed11a0ed75db9cd0b70c610793d5ca742a (diff)
downloadfreebsd-ports-gnome-94eaefe6cdc7fc3a273e2f46dd70e8fea8581704.tar.gz
freebsd-ports-gnome-94eaefe6cdc7fc3a273e2f46dd70e8fea8581704.tar.zst
freebsd-ports-gnome-94eaefe6cdc7fc3a273e2f46dd70e8fea8581704.zip
Add latex-subfloat 2.14.20030821,
latex-subfloat enables subnumbering of different floats (figures and tables) simular to the subequations-environment of the amsmath package. It does not the same as the subfigure package which generates subfigures within one normal figure. PR: ports/62035 Submitted by: hrs@FreeBSD.org
Diffstat (limited to 'print/latex-subfloat/Makefile')
-rw-r--r--print/latex-subfloat/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/print/latex-subfloat/Makefile b/print/latex-subfloat/Makefile
new file mode 100644
index 000000000000..0594e6c0946f
--- /dev/null
+++ b/print/latex-subfloat/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: latex-subfloat
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-subfloat
+PORTVERSION= 2.14.20030821
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/subfloat
+DISTFILES= Makefile subfloat.dtx subfloat.ins ${DOC_FILES}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package that enables subnumbering of different floats
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/tex
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= subfloat.dtx
+CLASS_FILES+= subfloat.sty
+CLASS_FILES+= subfloat.ins
+
+DOC_FILES= README
+DOC_FILES+= ChangeLog
+DOC_FILES+= subfloat.dvi
+DOC_FILES+= subfloat.xml
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${TEX_BIN} subfloat.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ @${MKTEXLSR}
+
+.include <bsd.port.mk>