aboutsummaryrefslogtreecommitdiffstats
path: root/print/latexdiff/Makefile
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-11-11 22:16:31 +0800
committerbarner <barner@FreeBSD.org>2005-11-11 22:16:31 +0800
commitb71054a3eaebadfbac49285f24d6ad882346b18a (patch)
tree49c9167a84f4b90223ce0eb3caa0f2a09dae091d /print/latexdiff/Makefile
parente04f050e6a329d6c2afd597c41fced3116627280 (diff)
downloadfreebsd-ports-gnome-b71054a3eaebadfbac49285f24d6ad882346b18a.tar.gz
freebsd-ports-gnome-b71054a3eaebadfbac49285f24d6ad882346b18a.tar.zst
freebsd-ports-gnome-b71054a3eaebadfbac49285f24d6ad882346b18a.zip
Add latexdiff 0.3,
determine and mark up significant differences between latex files. PR: 88353 Submitted by: Maxim Loginov <Zeliboba@mail.ru>
Diffstat (limited to 'print/latexdiff/Makefile')
-rw-r--r--print/latexdiff/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/print/latexdiff/Makefile b/print/latexdiff/Makefile
new file mode 100644
index 000000000000..582fbab8c0a9
--- /dev/null
+++ b/print/latexdiff/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: latexdiff
+# Date created: 01 Oct 2005
+# Whom: Maxim Loginov <Zeliboba@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latexdiff
+PORTVERSION= 0.3
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= support
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= Zeliboba@mail.ru
+COMMENT= Determine and mark up significant differences between latex files
+
+USE_PERL5_RUN= yes
+
+USE_GMAKE= no
+USE_ZIP= yes
+
+MAN1= latexdiff.1 \
+ latexrevise.1
+
+PLIST_FILES= bin/latexdiff \
+ bin/latexdiff-cvs \
+ bin/latexdiff-so \
+ bin/latexrevise
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above. Please use the lang/perl port to install it
+.endif
+
+do-build:
+# empty
+
+.include <bsd.port.post.mk>