aboutsummaryrefslogtreecommitdiffstats
path: root/print/latexdiff
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-31 05:42:26 +0800
committermiwi <miwi@FreeBSD.org>2008-05-31 05:42:26 +0800
commit7f3f61e5375b848607d48ba3d78b32f809083a39 (patch)
tree468fdd20d99cee7efe362cfc2cdd43d85405eeb7 /print/latexdiff
parentaaa7cb08776efc9019cac1d5242fe224107ed750 (diff)
downloadfreebsd-ports-gnome-7f3f61e5375b848607d48ba3d78b32f809083a39.tar.gz
freebsd-ports-gnome-7f3f61e5375b848607d48ba3d78b32f809083a39.tar.zst
freebsd-ports-gnome-7f3f61e5375b848607d48ba3d78b32f809083a39.zip
- Update to 0.5
PR: 123533 Submitted by: bf <bf2006a@yahoo.com> (maintainer)
Diffstat (limited to 'print/latexdiff')
-rw-r--r--print/latexdiff/Makefile31
-rw-r--r--print/latexdiff/distinfo6
-rw-r--r--print/latexdiff/files/patch-Makefile49
-rw-r--r--print/latexdiff/pkg-descr9
4 files changed, 33 insertions, 62 deletions
diff --git a/print/latexdiff/Makefile b/print/latexdiff/Makefile
index 323f90796212..51f6ddd13c9a 100644
--- a/print/latexdiff/Makefile
+++ b/print/latexdiff/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= latexdiff
-PORTVERSION= 0.3
-CATEGORIES= print
+PORTVERSION= 0.5
+CATEGORIES= print perl5
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support
DISTNAME= ${PORTNAME}
@@ -15,20 +15,37 @@ DISTNAME= ${PORTNAME}
MAINTAINER= Zeliboba@mail.ru
COMMENT= Determine and mark up significant differences between latex files
-USE_PERL5_RUN= yes
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ bash:${PORTSDIR}/shells/bash
-USE_GMAKE= no
+USE_PERL5_RUN= yes
USE_ZIP= yes
+NO_BUILD= yes
MAN1= latexdiff.1 \
+ latexdiff-vc.1 \
latexrevise.1
PLIST_FILES= bin/latexdiff \
- bin/latexdiff-cvs \
+ bin/latexdiff-fast \
bin/latexdiff-so \
+ bin/latexdiff-vc \
+ bin/latexdiff-wrap \
bin/latexrevise
-do-build:
-# empty
+post-patch:
+ ${REINPLACE_CMD} -e "s,\/bin\/bash,${LOCALBASE}\/bin\/bash," \
+ ${WRKSRC}/contrib/latexdiff-wrap
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin ${MANPREFIX}/man/man1
+ ( cd ${WRKSRC} && ${INSTALL_SCRIPT} latexdiff-fast latexdiff-so \
+ latexdiff-vc latexrevise contrib/latexdiff-wrap ${PREFIX}/bin && \
+ ${INSTALL_MAN} latexdiff.1 latexdiff-vc.1 latexrevise.1 \
+ ${MANPREFIX}/man/man1 )
+ ${LN} -s ${PREFIX}/bin/latexdiff-so ${PREFIX}/bin/latexdiff
+
+test:
+ ( cd ${WRKSRC} && ${MAKE} test-so test-fast )
.include <bsd.port.mk>
diff --git a/print/latexdiff/distinfo b/print/latexdiff/distinfo
index e0e3b50f4b13..e62b208add88 100644
--- a/print/latexdiff/distinfo
+++ b/print/latexdiff/distinfo
@@ -1,3 +1,3 @@
-MD5 (latexdiff.zip) = 955a9738995c874f31aaf6bc0fda6882
-SHA256 (latexdiff.zip) = 12d1265634bf609d2878cd6502e262e69dc18f6d907a979c4bb10af678290613
-SIZE (latexdiff.zip) = 291781
+MD5 (latexdiff.zip) = 70fdec50c25c5807e7ec071b88d4af49
+SHA256 (latexdiff.zip) = 7a99ac274c7552b1acf617d27866b40573469acafde0fb680231e58b2e08ddcf
+SIZE (latexdiff.zip) = 310412
diff --git a/print/latexdiff/files/patch-Makefile b/print/latexdiff/files/patch-Makefile
deleted file mode 100644
index 0859b3e150be..000000000000
--- a/print/latexdiff/files/patch-Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
---- Makefile.orig Tue Oct 4 04:36:54 2005
-+++ Makefile Fri Nov 11 15:00:19 2005
-@@ -2,7 +2,7 @@
- # For the current setting you will need root permission but
- # it is perfectly acceptable to choose user directories
- #
--INSTALLPATH = /usr/local
-+INSTALLPATH = ${PREFIX}
- INSTALLMANPATH = $(INSTALLPATH)/man
- INSTALLEXECPATH = $(INSTALLPATH)/bin
-
-@@ -15,28 +15,31 @@
- @echo "To install the version which uses the system Algorithm::Diff package type: make install-ext"
- @echo " "
-
-+dirs:
-+ mkdir -p $(INSTALLMANPATH)/man1 $(INSTALLEXECPATH)
-+
- install: install-so
-
- install-ext: install-latexdiff install-latexrevise install-latexdiff-cvs install-man
-
--install-so: install-latexdiff-so install-latexrevise install-latexdiff-cvs install-man
-+install-so: dirs install-latexdiff-so install-latexrevise install-latexdiff-cvs install-man
-
- install-man:
-- install latexrevise.1 latexdiff.1 $(INSTALLMANPATH)/man1
-+ ${BSD_INSTALL_MAN} latexrevise.1 latexdiff.1 $(INSTALLMANPATH)/man1
-
- install-latexdiff:
-- install latexdiff $(INSTALLEXECPATH)
-+ ${BSD_INSTALL_SCRIPT} latexdiff $(INSTALLEXECPATH)
-
- install-latexdiff-so:
- if [ -e $(INSTALLEXECPATH)/latexdiff ]; then rm $(INSTALLEXECPATH)/latexdiff; fi
-- install latexdiff-so $(INSTALLEXECPATH)
-+ ${BSD_INSTALL_SCRIPT} latexdiff-so $(INSTALLEXECPATH)
- cd $(INSTALLEXECPATH); ln -s latexdiff-so latexdiff
-
- install-latexrevise:
-- install latexrevise $(INSTALLEXECPATH)
-+ ${BSD_INSTALL_SCRIPT} latexrevise $(INSTALLEXECPATH)
-
- install-latexdiff-cvs:
-- install latexdiff-cvs $(INSTALLEXECPATH)
-+ ${BSD_INSTALL_SCRIPT} latexdiff-cvs $(INSTALLEXECPATH)
-
- test: test-so
-
diff --git a/print/latexdiff/pkg-descr b/print/latexdiff/pkg-descr
index 2e804580b86a..746cebd05476 100644
--- a/print/latexdiff/pkg-descr
+++ b/print/latexdiff/pkg-descr
@@ -1,6 +1,7 @@
-latexdiff is a Perl script, which compares two latex files and marks
+latexdiff is a Perl script that compares two latex files and marks
up significant differences between them (i.e. a diff for latex files).
- Various options are available for visual markup using standard latex
+
+Various options are available for visual markup using standard latex
packages such as "color.sty". Changes not directly affecting visible
text, for example in formatting commands, are still marked in
the latex source.
@@ -8,4 +9,6 @@ the latex source.
A rudimentary revision facilility is provided by another Perl script,
latexrevise, which accepts or rejects all changes. Manual
editing of the difference file can be used to override this default
-behaviour and accept or reject selected changes only.
+behaviour and accept or reject selected changes only. There are also
+scripts to handle multiple-file documents, and files under version
+control.