aboutsummaryrefslogtreecommitdiffstats
path: root/print/libgnomeprintmm
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2005-04-22 13:41:26 +0800
committerbland <bland@FreeBSD.org>2005-04-22 13:41:26 +0800
commitbb6e44f1a6fd5a23df61d91bf52ebdbd04d85680 (patch)
treec6bc890a4c418c48748c041ecfe134a009450b86 /print/libgnomeprintmm
parent4b2e3f9fa9b56c28d8bc1f6ee8825df89b39ce83 (diff)
downloadfreebsd-ports-gnome-bb6e44f1a6fd5a23df61d91bf52ebdbd04d85680.tar.gz
freebsd-ports-gnome-bb6e44f1a6fd5a23df61d91bf52ebdbd04d85680.tar.zst
freebsd-ports-gnome-bb6e44f1a6fd5a23df61d91bf52ebdbd04d85680.zip
Fix build failure triggered by pkgconfig update.
Diffstat (limited to 'print/libgnomeprintmm')
-rw-r--r--print/libgnomeprintmm/Makefile5
-rw-r--r--print/libgnomeprintmm/files/patch-tools__extra_defs_gen__Makefile.in11
2 files changed, 5 insertions, 11 deletions
diff --git a/print/libgnomeprintmm/Makefile b/print/libgnomeprintmm/Makefile
index d91a2a9737f1..e023ef869f8d 100644
--- a/print/libgnomeprintmm/Makefile
+++ b/print/libgnomeprintmm/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GCC= 3.4
USE_GNOME= gnomeprefix gnomehack libgnomeprint
INSTALLS_SHLIB= yes
@@ -29,6 +30,10 @@ CONFIGURE_ARGS= --enable-static
PLIST_SUB= VERSION="2.5" API_VERSION="2.6"
+post-patch:
+ @${REINPLACE_CMD} -e "s|\(-lglibmm\)|-L\$$(GMM_PROCDIR)/../.. \1|" \
+ ${WRKSRC}/tools/extra_defs_gen/Makefile.in
+
patch-autotools:
@(cd ${PATCH_WRKSRC}; \
for file in ${LIBTOOLFILES}; do \
diff --git a/print/libgnomeprintmm/files/patch-tools__extra_defs_gen__Makefile.in b/print/libgnomeprintmm/files/patch-tools__extra_defs_gen__Makefile.in
deleted file mode 100644
index ad005e718636..000000000000
--- a/print/libgnomeprintmm/files/patch-tools__extra_defs_gen__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/extra_defs_gen/Makefile.in.bak Tue Jun 8 19:58:29 2004
-+++ tools/extra_defs_gen/Makefile.in Fri Apr 22 12:25:56 2005
-@@ -119,7 +119,7 @@
- LIBGNOMEPRINTMM_VERSION = @LIBGNOMEPRINTMM_VERSION@
- LIBGNOMEPRINT_VERSION_NEEDED = @LIBGNOMEPRINT_VERSION_NEEDED@
- LIBOBJS = @LIBOBJS@
--LIBS = $(LIBGNOMEPRINTMM_LIBS) -lglibmm_generate_extra_defs-2.4
-+LIBS = $(LIBGNOMEPRINTMM_LIBS) -L$(GMM_PROCDIR)/../.. -lglibmm_generate_extra_defs-2.4
- LIBTOOL = @LIBTOOL@
- LN_S = @LN_S@
- LTLIBOBJS = @LTLIBOBJS@