aboutsummaryrefslogtreecommitdiffstats
path: root/print/libharu/files
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-04-22 23:13:41 +0800
committerKoop Mast <koop@beyonit.nl>2019-04-23 03:03:33 +0800
commit960c316bea2836e2a8c99ae97462b0c38436c760 (patch)
treebf58b9e5d114f0152783a7e726bae3be529f13d7 /print/libharu/files
parente2657d4b9033ebf6b3d68a6e0919339bc9d6d13e (diff)
downloadfreebsd-ports-gnome-960c316bea2836e2a8c99ae97462b0c38436c760.tar.gz
freebsd-ports-gnome-960c316bea2836e2a8c99ae97462b0c38436c760.tar.zst
freebsd-ports-gnome-960c316bea2836e2a8c99ae97462b0c38436c760.zip
print/libharu: Link with libm explicitly and attempt to unbreak on CURRENT
ld: error: src/libhpdf.so: undefined reference to cos ld: error: src/libhpdf.so: undefined reference to sin http://beefy12.nyi.freebsd.org/data/head-amd64-default/p499421_s346424/logs/errors/libharu-2.3.0_1.log https://github.com/libharu/libharu/pull/158
Diffstat (limited to 'print/libharu/files')
-rw-r--r--print/libharu/files/patch-CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/print/libharu/files/patch-CMakeLists.txt b/print/libharu/files/patch-CMakeLists.txt
index e2a943474d1e..45983863a210 100644
--- a/print/libharu/files/patch-CMakeLists.txt
+++ b/print/libharu/files/patch-CMakeLists.txt
@@ -9,7 +9,16 @@
# =======================================================================
# look for headers and libraries
# =======================================================================
-@@ -110,7 +112,6 @@ endif(PNG_FOUND)
+@@ -99,6 +101,8 @@ if(PNG_FOUND)
+ set(ADDITIONAL_LIBRARIES ${ADDITIONAL_LIBRARIES} ${PNG_LIBRARIES})
+ endif(PNG_FOUND)
+
++find_library(M_LIB m)
++set(ADDITIONAL_LIBRARIES ${ADDITIONAL_LIBRARIES} ${M_LIB})
+
+ # =======================================================================
+ # configure header files, add compiler flags
+@@ -110,7 +114,6 @@ endif(PNG_FOUND)
if(MSVC_VERSION GREATER 1399)
add_definitions(-D_CRT_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_DEPRECATE)
endif(MSVC_VERSION GREATER 1399)
@@ -17,7 +26,7 @@
# these are options
-@@ -210,9 +211,7 @@ set(
+@@ -210,9 +213,7 @@ set(
install(FILES ${haru_HDRS} DESTINATION include)
# install various files