aboutsummaryrefslogtreecommitdiffstats
path: root/print/lilypond
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-05-18 16:34:09 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-05-18 16:34:09 +0800
commit5e8aa8e242183f17d2e11c4362c45d9c76a9cac3 (patch)
treecaaa656be574648cdba12496f2269c86e6cf6a5b /print/lilypond
parent0c18ac8ef328907029f0417f59eb7a8d3ee72662 (diff)
downloadfreebsd-ports-gnome-5e8aa8e242183f17d2e11c4362c45d9c76a9cac3.tar.gz
freebsd-ports-gnome-5e8aa8e242183f17d2e11c4362c45d9c76a9cac3.tar.zst
freebsd-ports-gnome-5e8aa8e242183f17d2e11c4362c45d9c76a9cac3.zip
- Fix LICENSE
- Add LICENSE_FILE - Pet portlint - Switch to options helpers - Switch to new test framework Approved by: portmgr blanket
Diffstat (limited to 'print/lilypond')
-rw-r--r--print/lilypond/Makefile59
1 files changed, 25 insertions, 34 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index d80c09b6b400..10c941a87d24 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU music typesetter
-LICENSE= GPLv3
-
-OPTIONS_DEFINE= NLS
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= pdftexi2dvi:print/texinfo \
t1ascii:print/t1utils \
@@ -34,62 +33,54 @@ LIB_DEPENDS= libguile.so:lang/guile \
RUN_DEPENDS= mftrace:print/mftrace \
${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu
-INFO= internals \
- lilypond-changes \
- lilypond-contributor \
- lilypond-essay \
- lilypond-extending \
- lilypond-internals \
- lilypond-learning \
- lilypond-notation \
- lilypond-snippets \
- lilypond-usage \
- lilypond-web \
- music-glossary
-
USES= bison:build gettext ghostscript gmake pkgconfig perl5 \
python:2.7
USE_TEX= latex
USE_PERL5= build
USE_GNOME= pango
-
-MAKEFILE= GNUmakefile
-GNU_MAKEFILE= yes
#MAKE_JOBS_UNSAFE= yes
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts \
--with-python-include=${PYTHON_INCLUDEDIR}
CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
FLEX=${FLEX} YACC=${YACC}
+MAKEFILE= GNUmakefile
+GNU_MAKEFILE= yes
+
ALL_TARGET= all
+TEST_TARGET= test # fails with sig11
NO_CCACHE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
-.include <bsd.port.options.mk>
+INFO= internals \
+ lilypond-changes \
+ lilypond-contributor \
+ lilypond-essay \
+ lilypond-extending \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-notation \
+ lilypond-snippets \
+ lilypond-usage \
+ lilypond-web \
+ music-glossary
-.if ${PORT_OPTIONS:MNLS}
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
post-patch:
- ${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
- ${WRKSRC}/lily/include/includable-lexer.hh
-.if !${PORT_OPTIONS:MNLS}
- ${REINPLACE_CMD} -e '/^PO_FILES/s|= |= #|' ${WRKSRC}/${MAKEFILE}.in
-.endif
+ @${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
+ ${WRKSRC}/lily/include/includable-lexer.hh
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^PO_FILES/s|= |= #|' ${WRKSRC}/${MAKEFILE}.in
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lilypond
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lilypond/${PORTVERSION}/python/midi.so
@${LN} -fs ${DATADIR}/${PORTVERSION} ${STAGEDIR}${DATADIR}/current
-regression-test: build
- cd ${WRKSRC} && ${MAKE_CMD} -f ${MAKEFILE} test
-
.include <bsd.port.mk>