aboutsummaryrefslogtreecommitdiffstats
path: root/print/lpr-wrapper/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-10-13 10:09:46 +0800
committeredwin <edwin@FreeBSD.org>2005-10-13 10:09:46 +0800
commitaad4e82d81feed52fa36412932aac802557209cd (patch)
tree3d255736c80ffab6d95c49db046123a21b55506f /print/lpr-wrapper/Makefile
parentc4e67b895b36c28e8261b72f2df466c2489c189b (diff)
downloadfreebsd-ports-gnome-aad4e82d81feed52fa36412932aac802557209cd.tar.gz
freebsd-ports-gnome-aad4e82d81feed52fa36412932aac802557209cd.tar.zst
freebsd-ports-gnome-aad4e82d81feed52fa36412932aac802557209cd.zip
New Port : print/lpr-wrapper A user level printer frontend
New port for lpr-wrapper, a user level printer frontend Contains required ports print/libppd & print/psdim PR: ports/80255 Submitted by: Eric Masson <e-masson@kisoft-services.com>
Diffstat (limited to 'print/lpr-wrapper/Makefile')
-rw-r--r--print/lpr-wrapper/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/print/lpr-wrapper/Makefile b/print/lpr-wrapper/Makefile
new file mode 100644
index 000000000000..64fa4f51a7b6
--- /dev/null
+++ b/print/lpr-wrapper/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lpr-wrapper
+# Date created: 22 Apr 2005 17:00:00 CEST
+# Whom: e-masson@kisoft-services.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= lpr-wrapper
+PORTVERSION= 0.6
+CATEGORIES= print
+MASTER_SITES= http://www.mathstat.dal.ca/~selinger/lpr-wrapper/download/
+
+MAINTAINER= e-masson@kisoft-services.com
+COMMENT= A user level printer frontend
+
+#
+# define WITH_GHOSTSCRIPT_AFPL=yes for AFPL Postscript interpreter
+# instead of GNU one
+#
+USE_GHOSTSCRIPT_RUN= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS+= ppdfilt:${PORTSDIR}/print/libppd
+RUN_DEPENDS+= psdim:${PORTSDIR}/print/psdim
+RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
+.if defined(A4)
+RUN_DEPENDS+= pstops:${PORTSDIR}/print/psutils-a4
+.else
+RUN_DEPENDS+= pstops:${PORTSDIR}/print/psutils-letter
+.endif
+
+.include <bsd.port.mk>