aboutsummaryrefslogtreecommitdiffstats
path: root/print/lyx14/Makefile
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-05-03 22:54:23 +0800
committerdirk <dirk@FreeBSD.org>2000-05-03 22:54:23 +0800
commitdd577689a672a6c1870e179cb055158a987f9001 (patch)
tree6f1362b0f7e62183c405d478d2a3530926747b94 /print/lyx14/Makefile
parent17b6d50d9630ab7429fe48945b32049566487092 (diff)
downloadfreebsd-ports-gnome-dd577689a672a6c1870e179cb055158a987f9001.tar.gz
freebsd-ports-gnome-dd577689a672a6c1870e179cb055158a987f9001.tar.zst
freebsd-ports-gnome-dd577689a672a6c1870e179cb055158a987f9001.zip
- upgrade to 1.1.4.3 (patch-1.1.4fix3)
- use shared intl.1 instead of supplied static library PR: ports/17267, ports/17268
Diffstat (limited to 'print/lyx14/Makefile')
-rw-r--r--print/lyx14/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index d232f6cbec3d..4719ac6c40d4 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= 1.1.4.2
+PORTVERSION= 1.1.4.3
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://ftp.sdsc.edu/pub/other/lyx/stable/ \
@@ -14,7 +14,7 @@ MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
DISTNAME= lyx-1.1.4
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.1.4fix1.gz patch-1.1.4fix2.gz
+PATCHFILES= patch-1.1.4fix1.gz patch-1.1.4fix2.gz patch-1.1.4fix3.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= dirk@FreeBSD.org
@@ -25,14 +25,14 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm
+ Xpm.4:${PORTSDIR}/graphics/xpm \
+ intl.1:${PORTSDIR}/devel/gettext
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-extra-lib=${X11BASE}/lib \
- --with-extra-inc="${X11BASE}/include ${X11BASE}/include/X11 ${LOCALBASE}/include" \
- --with-included-gettext
+CONFIGURE_ARGS= --with-extra-lib="${X11BASE}/lib ${LOCALBASE}/lib" \
+ --with-extra-inc="${X11BASE}/include ${LOCALBASE}/include"
MAN1= lyx.1 reLyX.1
.if !defined(WITH_ISPELL)