aboutsummaryrefslogtreecommitdiffstats
path: root/print/p5-Net-Printer/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-08-29 04:15:39 +0800
committererwin <erwin@FreeBSD.org>2003-08-29 04:15:39 +0800
commit1b4e5292e5f64a29e997c39146485da08f61ab73 (patch)
tree820c51990231e55651dd7c87ddd5e5e78cc740b6 /print/p5-Net-Printer/Makefile
parenta022f1f414bc3f788ccb0e8f76515a54c59ee491 (diff)
downloadfreebsd-ports-gnome-1b4e5292e5f64a29e997c39146485da08f61ab73.tar.gz
freebsd-ports-gnome-1b4e5292e5f64a29e997c39146485da08f61ab73.tar.zst
freebsd-ports-gnome-1b4e5292e5f64a29e997c39146485da08f61ab73.zip
Add p5-Net-Printer 0.32, perl extension for direct-to-lpd printing.
Perl module for directly printing to a print server/printer without having to create a pipe to either lpr or lp. This essentially mimics what the BSD LPR program does by connecting directly to the line printer printer port (almost always 515), and transmitting the data and control information to the print server. PR: 55577 Submitted by: andrew@scoop.co.nz
Diffstat (limited to 'print/p5-Net-Printer/Makefile')
-rw-r--r--print/p5-Net-Printer/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/print/p5-Net-Printer/Makefile b/print/p5-Net-Printer/Makefile
new file mode 100644
index 000000000000..cea738e2ab7f
--- /dev/null
+++ b/print/p5-Net-Printer/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-Printer
+# Date created: 14 August 2003
+# Whom: andrew@scoop.co.nz
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Printer
+PORTVERSION= 0.32
+CATEGORIES= print perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrew@scoop.co.nz
+COMMENT= Perl extension for direct-to-lpd printing
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Printer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>