aboutsummaryrefslogtreecommitdiffstats
path: root/print/passivetex/Makefile
diff options
context:
space:
mode:
authornik <nik@FreeBSD.org>2002-06-04 19:28:57 +0800
committernik <nik@FreeBSD.org>2002-06-04 19:28:57 +0800
commit5d172d651718b74144a01c7fc2a19d3e4767389c (patch)
tree1dbb1589a8e11129d9306c84b50ee33f82781891 /print/passivetex/Makefile
parent77578d32ee3b7d666f0da437ed64da7e3ba90d89 (diff)
downloadfreebsd-ports-gnome-5d172d651718b74144a01c7fc2a19d3e4767389c.tar.gz
freebsd-ports-gnome-5d172d651718b74144a01c7fc2a19d3e4767389c.tar.zst
freebsd-ports-gnome-5d172d651718b74144a01c7fc2a19d3e4767389c.zip
Add PassiveTeX. PassiveTeX is an XML Formatting Objects processor,
written in TeX (!). To produce high quality PS or PDF output from XML files, you first convert them to the FO standard, and then run PassiveTeX over them.
Diffstat (limited to 'print/passivetex/Makefile')
-rw-r--r--print/passivetex/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/print/passivetex/Makefile b/print/passivetex/Makefile
new file mode 100644
index 000000000000..55fef59a4352
--- /dev/null
+++ b/print/passivetex/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: passivetex
+# Date created: 9 May 2002
+# Whom: Nik Clayton <nik@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= passivetex
+PORTVERSION= 1.0
+CATEGORIES= print
+MASTER_SITES= http://www.hcu.ox.ac.uk/TEI/Software/passivetex/
+DISTFILES= passivetex.zip
+
+MAINTAINER= nik@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/texmf/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex
+
+DIST_SUBDIR= passivetex
+NO_BUILD= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/passivetex
+
+MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/share/texmf/web2c
+
+MESSAGE= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch: patch-message
+
+patch-message:
+ @${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${MESSAGE} > ${PKGMESSAGE}
+
+do-install:
+ @cd ${WRKSRC}; TEXMFMAIN=$$(kpsewhich -expand-var '$$TEXMFMAIN'); \
+ ${MKDIR} -m 555 $$TEXMFMAIN/tex/passivetex; \
+ ${INSTALL_DATA} dummyels.sty fotex.xmt fotex.sty mlnames.sty ucharacters.sty unicode.sty $$TEXMFMAIN/tex/passivetex;
+
+post-install: rebuild-tex-database display-message
+
+rebuild-tex-database:
+ ${LOCALBASE}/bin/mktexlsr
+
+display-message:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>