aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdftk
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-12-31 07:54:59 +0800
committerglarkin <glarkin@FreeBSD.org>2009-12-31 07:54:59 +0800
commit2577e0f9aa55017233db830112223afb716680e0 (patch)
tree5d04e07b957148dd8e4de02ed49c27e18cf87552 /print/pdftk
parent630525b8a037afc45dcf839f9b9df28f70624fd4 (diff)
downloadfreebsd-ports-gnome-2577e0f9aa55017233db830112223afb716680e0.tar.gz
freebsd-ports-gnome-2577e0f9aa55017233db830112223afb716680e0.tar.zst
freebsd-ports-gnome-2577e0f9aa55017233db830112223afb716680e0.zip
- Unbreak and enable amd64 build, now that gcc42 port builds gcj42 on
i386 and amd64
Diffstat (limited to 'print/pdftk')
-rw-r--r--print/pdftk/Makefile18
-rw-r--r--print/pdftk/files/patch-Makefile.Generic11
2 files changed, 21 insertions, 8 deletions
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index fabb28646148..73821db01d56 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pdftk
PORTVERSION= 1.41
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://www.pdfhacks.com/pdftk/ \
http://www.accesspdf.com/pdftk/
@@ -15,21 +16,22 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}.${PORTVERSION:E}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= A simple tool for doing everyday things with PDF documents
-# gcj/libgcj don't exist on these platforms
-NOT_FOR_ARCHS= amd64 ia64 sparc64
+# Make this explicit for all OS versions. For __FreeBSD_version < 700042,
+# we need to build gcc 4.2+ to get gcj42, and for OS versions with gcc 4.2+
+# in the base system, we need to build the port anyway to get gcj42.
+BUILD_DEPENDS= gcj${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF}
# Get gcc version suffix without the dot in USE_GCC
CSUFF= ${_USE_GCC:S/.//}
-# needs gcj
-LIB_DEPENDS= gcj:${PORTSDIR}/lang/gcc${CSUFF}
-
-BROKEN= gcj is not currently available in the GCC toolchain
-
-USE_GCC= 4.4+
+USE_GCC= 4.2+
USE_GMAKE= yes
USE_ICONV= yes
+# gcj/libgcj don't exist on some platforms
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= GNU gcj does not exist on this platform
+
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
MAKEFILE= Makefile.Generic
diff --git a/print/pdftk/files/patch-Makefile.Generic b/print/pdftk/files/patch-Makefile.Generic
new file mode 100644
index 000000000000..6fd62c877336
--- /dev/null
+++ b/print/pdftk/files/patch-Makefile.Generic
@@ -0,0 +1,11 @@
+--- ./Makefile.Generic.orig 2009-12-10 15:50:42.000000000 -0500
++++ ./Makefile.Generic 2009-12-10 15:50:42.000000000 -0500
+@@ -28,7 +28,7 @@
+
+ # itext compiler flags
+ # -O3 might cause pdftk to segfault on cat operation (gcc 3.4.4)
+-export GCJFLAGS= -L/usr/local/lib -O2
++export GCJFLAGS= -L/usr/local/lib -O2 -w
+
+ #
+ export ARFLAGS= rs