aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdftk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /print/pdftk
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'print/pdftk')
-rw-r--r--print/pdftk/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index edc06a900990..9107868669e8 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -17,10 +17,10 @@ BUILD_DEPENDS= gcj${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF} \
gcjh${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF} \
cpp${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF}
-# Get gcc version suffix without the dot in USE_GCC
+# Get GCC version suffix without the dot in USE_GCC
CSUFF= ${_USE_GCC:S/.//}
-USE_GCC= 4.6+
+USE_GCC= yes
USE_GMAKE= yes
USES= iconv
USE_LDCONFIG= ${PREFIX}/lib/gcc${CSUFF}