aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdq/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-07-11 16:43:49 +0800
committersobomax <sobomax@FreeBSD.org>2000-07-11 16:43:49 +0800
commit61e8f533edc3b57b1ff6a621ab6f519f86f1f521 (patch)
treeb322ef2b5e87cbe3e625b8e1ccad10b94fd5553d /print/pdq/Makefile
parent254773998d400a59b42a08df1d5904db3a5431f2 (diff)
downloadfreebsd-ports-gnome-61e8f533edc3b57b1ff6a621ab6f519f86f1f521.tar.gz
freebsd-ports-gnome-61e8f533edc3b57b1ff6a621ab6f519f86f1f521.tar.zst
freebsd-ports-gnome-61e8f533edc3b57b1ff6a621ab6f519f86f1f521.zip
Update 2.2.1. Also support ${PREFIX} properly.
Diffstat (limited to 'print/pdq/Makefile')
-rw-r--r--print/pdq/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/print/pdq/Makefile b/print/pdq/Makefile
index 065eba93960b..8f4bd64b8338 100644
--- a/print/pdq/Makefile
+++ b/print/pdq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pdq
-PORTVERSION= 2.1.1
+PORTVERSION= 2.2.1
CATEGORIES= print
MASTER_SITES= ftp://feynman.tam.uiuc.edu/pub/pdq/
EXTRACT_SUFX= .tgz
@@ -19,6 +19,7 @@ GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-pdqlibdir=${PREFIX}/etc/pdq
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
@@ -26,12 +27,11 @@ MAN1= lpd_cancel.1 lpd_print.1 lpd_status.1 pdq.1 xpdq.1
MAN5= printrc.5
post-install:
- ${CP} ${WRKSRC}/sample_etc_printrc ${PREFIX}/etc/printrc.sample
strip ${PREFIX}/bin/pdq
strip ${PREFIX}/bin/xpdq
strip ${PREFIX}/bin/lpd_cancel
strip ${PREFIX}/bin/lpd_print
strip ${PREFIX}/bin/lpd_status
- @${CAT} pkg/MESSAGE
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' pkg/MESSAGE
.include <bsd.port.mk>