aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdq/Makefile
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>1999-05-17 18:32:43 +0800
committerfoxfair <foxfair@FreeBSD.org>1999-05-17 18:32:43 +0800
commitd14701e2e875561370c7721b18b950638472d1f9 (patch)
tree1c05148986b1f152e943637c54bfd5deb9e3104b /print/pdq/Makefile
parente61634e1c15a63e9d86f55a34b3242446d7bd382 (diff)
downloadfreebsd-ports-gnome-d14701e2e875561370c7721b18b950638472d1f9.tar.gz
freebsd-ports-gnome-d14701e2e875561370c7721b18b950638472d1f9.tar.zst
freebsd-ports-gnome-d14701e2e875561370c7721b18b950638472d1f9.zip
PR: 11721
Submitted by: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
Diffstat (limited to 'print/pdq/Makefile')
-rw-r--r--print/pdq/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/print/pdq/Makefile b/print/pdq/Makefile
new file mode 100644
index 000000000000..e2cd41612252
--- /dev/null
+++ b/print/pdq/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pdq
+# Version required: 2.1.1
+# Date created: 15 May 1999
+# Whom: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
+#
+# $Id$
+#
+
+DISTNAME= pdq-2.1.1
+CATEGORIES= print
+MASTER_SITES= ftp://feynman.tam.uiuc.edu/pub/pdq/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+
+LIB_DEPENDS= gtk12.1:${PORTSDIR}/x11-toolkits/gtk12
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib12-config"
+
+MAN1= lpd_cancel.1 lpd_print.1 lpd_status.1 pdq.1 xpdq.1
+MAN5= printrc.5
+
+post-install:
+ ${CP} ${WRKSRC}/sample_etc_printrc ${PREFIX}/etc/printrc.sample
+ strip ${PREFIX}/bin/pdq
+ strip ${PREFIX}/bin/xpdq
+ strip ${PREFIX}/bin/lpd_cancel
+ strip ${PREFIX}/bin/lpd_print
+ strip ${PREFIX}/bin/lpd_status
+ @${ECHO} '*******************************************************'
+ @${ECHO} '* *'
+ @${ECHO} '* Please copy /usr/local/etc/printrc.sample to *'
+ @${ECHO} '* /usr/local/etc/printrc by yourself, thanks. *'
+ @${ECHO} '* *'
+ @${ECHO} '*******************************************************'
+
+.include <bsd.port.mk>