aboutsummaryrefslogtreecommitdiffstats
path: root/print/pecl-haru/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-24 02:12:48 +0800
committermiwi <miwi@FreeBSD.org>2008-11-24 02:12:48 +0800
commit9a0024af1839b5980b728ab72b4f45e2e2407a96 (patch)
tree7751a2b8d9363028c17362b022b79341f6ff68d7 /print/pecl-haru/Makefile
parent42715faf61f01f577810f587c621c7159a61807d (diff)
downloadfreebsd-ports-gnome-9a0024af1839b5980b728ab72b4f45e2e2407a96.tar.gz
freebsd-ports-gnome-9a0024af1839b5980b728ab72b4f45e2e2407a96.tar.zst
freebsd-ports-gnome-9a0024af1839b5980b728ab72b4f45e2e2407a96.zip
The PECL-haru extension provides bindings to the
libHaru library. libHaru is a free, cross platform, and Open Source library for generating PDF files. WWW: http://pecl.php.net/package/haru/ PR: ports/129033 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'print/pecl-haru/Makefile')
-rw-r--r--print/pecl-haru/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/print/pecl-haru/Makefile b/print/pecl-haru/Makefile
new file mode 100644
index 000000000000..399b7796f404
--- /dev/null
+++ b/print/pecl-haru/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pecl-haru
+# Date created: 20 Nov 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= haru
+PORTVERSION= 1.0.0
+CATEGORIES= print pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+#DIST_SUBDIR= PECL
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A PECL extension to Haru PDF functions
+
+BUILD_DEPENDS= ${LOCALBASE}/include/hpdf.h:${PORTSDIR}/print/libharu
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS+= --with-haru=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>