aboutsummaryrefslogtreecommitdiffstats
path: root/print/pmw/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-29 20:11:59 +0800
committerpav <pav@FreeBSD.org>2004-05-29 20:11:59 +0800
commit3b1e6f859cd7046187340b8833b1bcbaedbf9e6d (patch)
treef7ce41b9b820612a15dc3bd6f8c9eb0a16c39a1f /print/pmw/Makefile
parent2d2495cfd683734a2e600bb309920357c000b388 (diff)
downloadfreebsd-ports-gnome-3b1e6f859cd7046187340b8833b1bcbaedbf9e6d.tar.gz
freebsd-ports-gnome-3b1e6f859cd7046187340b8833b1bcbaedbf9e6d.tar.zst
freebsd-ports-gnome-3b1e6f859cd7046187340b8833b1bcbaedbf9e6d.zip
Add pmw, a computer program for high quality music typesetting.
PMW operates by reading an input file containing an encoded description of the music; such a file can be constructed using any text editor or word processor. The music encoding is very straightforward and compact, and quick to enter. PR: ports/67283 Submitted by: Brian Candler <B.Candler@pobox.com>
Diffstat (limited to 'print/pmw/Makefile')
-rw-r--r--print/pmw/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/print/pmw/Makefile b/print/pmw/Makefile
new file mode 100644
index 000000000000..4588ce0fef92
--- /dev/null
+++ b/print/pmw/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: pmw
+# Date Created: 28 May 2004
+# Whom: Brian Candler <B.Candler@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmw
+PORTVERSION= 4.05
+CATEGORIES= print audio
+MASTER_SITES= http://www.quercite.com/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= High quality music typesetting program
+
+ALL_TARGET= build
+GNU_CONFIGURE= yes
+MAN1= pmw.1
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog spec.pdf
+.endif
+
+post-patch:
+ @${CAT} ${MASTERDIR}/pkg-message | ${SED} 's|%%PREFIX%%|${PREFIX}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g' > ${PKGMESSAGE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${i} ${DOCSDIR}/
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>