aboutsummaryrefslogtreecommitdiffstats
path: root/print/pslib/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-07-13 10:45:48 +0800
committerijliao <ijliao@FreeBSD.org>2004-07-13 10:45:48 +0800
commit3e56f61548252eee0138e88a7dfd6021d399238e (patch)
treea90086b5a6e93269ee64232643c6d5e14f6d5d85 /print/pslib/Makefile
parent454ce599b256a45518168cb7ed759e85a1aebfdc (diff)
downloadfreebsd-ports-gnome-3e56f61548252eee0138e88a7dfd6021d399238e.tar.gz
freebsd-ports-gnome-3e56f61548252eee0138e88a7dfd6021d399238e.tar.zst
freebsd-ports-gnome-3e56f61548252eee0138e88a7dfd6021d399238e.zip
add pslib 0.2.2
A C-library for generating multi page PostScript documents
Diffstat (limited to 'print/pslib/Makefile')
-rw-r--r--print/pslib/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
new file mode 100644
index 000000000000..c6765f906352
--- /dev/null
+++ b/print/pslib/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: pslib
+# Date created: Jul 13, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pslib
+PORTVERSION= 0.2.2
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A C-library for generating multi page PostScript documents
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GETTEXT= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>