aboutsummaryrefslogtreecommitdiffstats
path: root/print/pslib
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2010-08-28 18:57:19 +0800
committermva <mva@FreeBSD.org>2010-08-28 18:57:19 +0800
commit20f3776b6f6fca21beebd3c5a96af346e33b8933 (patch)
treedcfb4da5dd9e3047cba13de3908462b5efe00c50 /print/pslib
parentc16abb705657e36389ba783d26251531c6936bba (diff)
downloadfreebsd-ports-gnome-20f3776b6f6fca21beebd3c5a96af346e33b8933.tar.gz
freebsd-ports-gnome-20f3776b6f6fca21beebd3c5a96af346e33b8933.tar.zst
freebsd-ports-gnome-20f3776b6f6fca21beebd3c5a96af346e33b8933.zip
- Add proper libpng 1.4 compatibility
Submitted by: Alan Garfield <alan@auspc.com.au> via mail
Diffstat (limited to 'print/pslib')
-rw-r--r--print/pslib/Makefile2
-rw-r--r--print/pslib/files/patch-src-pslib.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 3f4f3623e96e..6fbd5176f0b0 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pslib
PORTVERSION= 0.4.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print
MASTER_SITES= SF
diff --git a/print/pslib/files/patch-src-pslib.c b/print/pslib/files/patch-src-pslib.c
new file mode 100644
index 000000000000..089e97b4a9c5
--- /dev/null
+++ b/print/pslib/files/patch-src-pslib.c
@@ -0,0 +1,11 @@
+--- src/pslib.c.orig 2010-08-27 08:20:08.000000000 +0200
++++ src/pslib.c 2010-08-27 08:20:29.000000000 +0200
+@@ -4600,7 +4600,7 @@
+
+ /* Expand grayscale images to the full 8 bits from 1, 2, or 4 bits/pixel */
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+
+ png_read_update_info(png_ptr, info_ptr);
+ #else