aboutsummaryrefslogtreecommitdiffstats
path: root/print/py-rtf/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2005-05-11 19:27:28 +0800
committertg <tg@FreeBSD.org>2005-05-11 19:27:28 +0800
commitbe226a3480b603ea8319b41d557f6a6f9161a924 (patch)
treee7b28417639772ea2e259beb172fafa1ccc92a9a /print/py-rtf/Makefile
parented81e80da4853c6d2812e61f25422dc36f6219b4 (diff)
downloadfreebsd-ports-gnome-be226a3480b603ea8319b41d557f6a6f9161a924.tar.gz
freebsd-ports-gnome-be226a3480b603ea8319b41d557f6a6f9161a924.tar.zst
freebsd-ports-gnome-be226a3480b603ea8319b41d557f6a6f9161a924.zip
New port py-rtf, a library to create RTF documents using the Python language.
Diffstat (limited to 'print/py-rtf/Makefile')
-rw-r--r--print/py-rtf/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/print/py-rtf/Makefile b/print/py-rtf/Makefile
new file mode 100644
index 000000000000..21eb3ad3ec00
--- /dev/null
+++ b/print/py-rtf/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: PyRTF
+# Date created: 09 May 2005
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtf
+PORTVERSION= 0.45
+CATEGORIES= print python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyrtf
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyRTF-${PORTVERSION}
+
+MAINTAINER= tg@FreeBSD.org
+COMMENT= Library to create RTF documents using the Python language
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/py-rtf
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+
+.include <bsd.port.mk>