aboutsummaryrefslogtreecommitdiffstats
path: root/print/rlpr/files
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-03-24 08:11:03 +0800
committerjedgar <jedgar@FreeBSD.org>2000-03-24 08:11:03 +0800
commite9ba1f3a82024c71d7010d5477d650076f30a765 (patch)
tree1cf21ebfb1dcfd0afcd88a103596a0d2ba40387c /print/rlpr/files
parent80a3d3b854ce5897a58bd093b976afa09e9af197 (diff)
downloadfreebsd-ports-gnome-e9ba1f3a82024c71d7010d5477d650076f30a765.tar.gz
freebsd-ports-gnome-e9ba1f3a82024c71d7010d5477d650076f30a765.tar.zst
freebsd-ports-gnome-e9ba1f3a82024c71d7010d5477d650076f30a765.zip
Update port to 2.02
* Remove nonfunctional nls support PR: 17553 Submitted by: Maintainer
Diffstat (limited to 'print/rlpr/files')
-rw-r--r--print/rlpr/files/patch-ab16
-rw-r--r--print/rlpr/files/patch-ac53
2 files changed, 69 insertions, 0 deletions
diff --git a/print/rlpr/files/patch-ab b/print/rlpr/files/patch-ab
new file mode 100644
index 000000000000..e015e61ac59f
--- /dev/null
+++ b/print/rlpr/files/patch-ab
@@ -0,0 +1,16 @@
+--- src/Makefile.in Sat Sep 4 22:29:16 1999
++++ src/Makefile.in Tue Mar 21 23:05:50 2000
+@@ -90,4 +90,4 @@
+ LDFLAGS = -L../lib
+-LIBS = @INTLLIBS@ -lrlpr
+-INCLUDES = -I../intl -I../lib -DLOCALEDIR=\"$(localedir)\"
++LIBS = -lrlpr
++INCLUDES = -I../lib -DLOCALEDIR=\"$(localedir)\"
+
+--- Makefile.in Sat Sep 4 22:29:12 1999
++++ Makefile.in Tue Mar 21 23:07:50 2000
+@@ -89,3 +89,3 @@
+ EXTRA_DIST = INSTALL.generic $(PACKAGE)-$(VERSION).lsm
+-SUBDIRS = po intl lib man src
++SUBDIRS = lib man src
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/print/rlpr/files/patch-ac b/print/rlpr/files/patch-ac
new file mode 100644
index 000000000000..c0803a738c57
--- /dev/null
+++ b/print/rlpr/files/patch-ac
@@ -0,0 +1,53 @@
+--- src/rlpq.c Mon May 3 21:50:22 1999
++++ src/rlpq.c Tue Mar 21 23:29:36 2000
+@@ -65,4 +66,6 @@
+ setlocale(LC_ALL, "");
++#ifdef ENABLE_NLS
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+--- src/rlpr.c Sat Sep 4 22:09:36 1999
++++ src/rlpr.c Tue Mar 21 23:24:48 2000
+@@ -79,4 +79,6 @@
+ setlocale(LC_ALL, "");
++#ifdef ENABLE_NLS
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+--- src/rlprd.c Mon May 3 21:50:29 1999
++++ src/rlprd.c Tue Mar 21 23:31:12 2000
+@@ -75,4 +75,6 @@
+ setlocale(LC_ALL, "");
++#ifdef ENABLE_NLS
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+--- src/rlprm.c Mon May 3 21:50:22 1999
++++ src/rlprm.c Tue Mar 21 23:30:22 2000
+@@ -63,4 +64,6 @@
+ setlocale(LC_ALL, "");
++#ifdef ENABLE_NLS
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+--- src/intl.h Mon May 3 21:48:39 1999
++++ src/intl.h Wed Mar 22 12:40:02 2000
+@@ -19,7 +19,14 @@
+
++#ifdef ENABLE_NLS
+ #include <libintl.h>
++#endif
+ #include <locale.h>
+
++#ifdef ENABLE_NLS
+ #define _(string) gettext(string)
+ #define N_(string) gettext_noop(string)
++#else
++#define _(string) (string)
++#define N_(string) (string)
++#endif
+