aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus-devel/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2012-05-29 06:55:32 +0800
committerbeech <beech@FreeBSD.org>2012-05-29 06:55:32 +0800
commit4e16fc3c616d2a8034063dc7ae4805ec9f2a336a (patch)
tree498e04b882f692e508c45c4cb547ef02ca1c567d /print/scribus-devel/Makefile
parent4b5291e53af536ea52ac5d240e977198738d151c (diff)
downloadfreebsd-ports-gnome-4e16fc3c616d2a8034063dc7ae4805ec9f2a336a.tar.gz
freebsd-ports-gnome-4e16fc3c616d2a8034063dc7ae4805ec9f2a336a.tar.zst
freebsd-ports-gnome-4e16fc3c616d2a8034063dc7ae4805ec9f2a336a.zip
- Update to 1.5.0
- Using SVN now PR: ports/168215 Submitted by: lbartoletti <coder@tuxfamily.org> (maintainer)
Diffstat (limited to 'print/scribus-devel/Makefile')
-rw-r--r--print/scribus-devel/Makefile61
1 files changed, 41 insertions, 20 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 4b115e8f820b..5969b32c44f6 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -1,36 +1,37 @@
# Ports collection makefile for: scribus
-# Date created: Mar 15, 2002
-# Whom: ijliao
+# Date created: 2012-05-20
+# Whom: lbartoletti <coer@tuxfamily.org>
#
# $FreeBSD$
#
PORTNAME= scribus
-PORTVERSION= 1.3.9
+PORTVERSION= 1.5.0
CATEGORIES= print editors
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-devel/${PORTVERSION} \
- http://www.scribus.net/downloads/${PORTVERSION}/
-PKGNAMESUFFIX= -devel
+MASTER_SITES= http://download.tuxfamily.org/bartcoding/FreeBSD/ \
+ ${MASTER_SITE_LOCAL}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${SVN_REV}
MAINTAINER= coder@tuxfamily.org
COMMENT= A comprehensive desktop publishing program
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms.1:${PORTSDIR}/graphics/lcms \
- png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- cups.2:${PORTSDIR}/print/cups-base \
- freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- podofo.0:${PORTSDIR}/graphics/podofo \
- boost_thread.4:${PORTSDIR}/devel/boost-libs \
- aspell.16:${PORTSDIR}/textproc/aspell \
- cairo.2:${PORTSDIR}/graphics/cairo \
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ lcms:${PORTSDIR}/graphics/lcms \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ cups:${PORTSDIR}/print/cups-base \
+ freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ podofo:${PORTSDIR}/graphics/podofo \
+ boost_thread:${PORTSDIR}/devel/boost-libs \
+ aspell:${PORTSDIR}/textproc/aspell \
+ cairo:${PORTSDIR}/graphics/cairo \
execinfo:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging \
update-mime-database:${PORTSDIR}/misc/shared-mime-info
+USE_SVN= yes
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= gui linguist_build moc_build qmake_build rcc_build uic_build xml network
@@ -38,17 +39,37 @@ USE_GNOME= desktopfileutils libartlgpl2 libxml2 pkgconfig
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_CMAKE= yes
-MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
MAN1= scribus.1
-MANLANG= "" pl de
+MANLANG= "" de pl
MANCOMPRESSED= no
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+SVN_REV= 17518 # svn tip at epoch 2009120801
+SVNROOT_URI= svn://scribus.net/trunk/Scribus
+
+.include <bsd.port.pre.mk>
+
post-install:
${LN} ${DATADIR}/icons/scribus.png ${PREFIX}/share/pixmaps/
-update-desktop-database
-update-mime-database ${PREFIX}/share/mime
+#
+# To roll snapshot: as bart (or other maintainer) : make BOOTSTRAP=defined fetch
+#
+.if defined(BOOTSTRAP)
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} ${SVNROOT_URI} ${WRKSRC}
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+.if ${USER} == bart
+ ${CHMOD} ugo+r ${DISTDIR}/${DISTNAME}.tar.bz2
+ scp -p ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif # defined(BOOTSTRAP)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>