aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus/Makefile
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-04-29 04:36:45 +0800
committermarkus <markus@FreeBSD.org>2004-04-29 04:36:45 +0800
commit3360d54da46b7fc5badcc9467ccf9e39fd0d8459 (patch)
treedfbefa2998ac77f9c646dd368d08e247b7921ece /print/scribus/Makefile
parent012a44245e1c1aad054d89ccea7e5e6ab41782d1 (diff)
downloadfreebsd-ports-gnome-3360d54da46b7fc5badcc9467ccf9e39fd0d8459.tar.gz
freebsd-ports-gnome-3360d54da46b7fc5badcc9467ccf9e39fd0d8459.tar.zst
freebsd-ports-gnome-3360d54da46b7fc5badcc9467ccf9e39fd0d8459.zip
- Update to 1.1.6
- respect CFLAGS
Diffstat (limited to 'print/scribus/Makefile')
-rw-r--r--print/scribus/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 53bdbd36a232..16754339e541 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -7,23 +7,32 @@
#
PORTNAME= scribus
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.1.6
CATEGORIES= print editors
MASTER_SITES= http://web2.altmuehlnet.de/fschmid/ \
- http://scribus.planetmirror.com/
+ http://scribus.planetmirror.com/ \
+ http://mirrors.ntua.gr/Scribus/ \
+ http://ftp.ntua.gr/pub/gnu/scribus/ \
+ ftp://ftp.ntua.gr/pub/gnu/scribus/
MAINTAINER= ports@FreeBSD.org
COMMENT= A comprehensive desktop publishing program
-USE_GHOSTSCRIPT_RUN= yes
+LIB_DEPENDS= art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2 \
+ lcms:${PORTSDIR}/graphics/lcms \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ cups.2:${PORTSDIR}/print/cups-base \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+USE_GHOSTSCRIPT_RUN= yes
USE_QT_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_PYTHON= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/scribus/libs \
@@ -40,6 +49,7 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g; \
+ s|-O2||g' ${WRKSRC}/configure
.include <bsd.port.mk>