aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-11-15 11:49:20 +0800
committeralane <alane@FreeBSD.org>2002-11-15 11:49:20 +0800
commit69385e40a5ec01b5317dd1e3af3967f0436c3c21 (patch)
tree73ae498572a9b06fa750a15681a41ffeb20ef9a1 /print/scribus/Makefile
parent359b946621093894374d70dac83b792a83ee5475 (diff)
downloadfreebsd-ports-gnome-69385e40a5ec01b5317dd1e3af3967f0436c3c21.tar.gz
freebsd-ports-gnome-69385e40a5ec01b5317dd1e3af3967f0436c3c21.tar.zst
freebsd-ports-gnome-69385e40a5ec01b5317dd1e3af3967f0436c3c21.zip
1. Updated to 0.9.1.
2. Got it to build (ohh, the pain). 3. Give up maintainership because I don't have time to fight with it.
Diffstat (limited to 'print/scribus/Makefile')
-rw-r--r--print/scribus/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index d380cfb2a9d3..32fcf257e57e 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -7,28 +7,31 @@
#
PORTNAME= scribus
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9.1
+PORTREVISION= 0
CATEGORIES= print editors
MASTER_SITES= http://web2.altmuehlnet.de/fschmid/
DIST_SUBDIR= ${PORTNAME}
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= Fonts.diff Palette.diff
-PATCH_DIST_STRIP= -p1
+#PATCH_SITES= ${MASTER_SITES}
+#PATCHFILES=
+#PATCH_DIST_STRIP= -p1
-MAINTAINER= alane@freebsd.org
+MAINTAINER= freebsd-ports@freebsd.org
RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
+BROKEN= "crashes on startup"
+
USE_QT_VER= 3
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/share/scribus/libs \
%%PREFIX%%/share/scribus/plugins
-BROKEN= "This program terminates with a SIGBUS or simply hangs"
+QTCFGLIBS+= -lm
post-patch::
${FIND} ${WRKSRC} -type f \
@@ -42,8 +45,8 @@ post-patch::
${WRKSRC}/scribus/Makefile.in
.endif # defined(NOPORTDOCS)
-post-configure::
- ${FIND} ${WRKSRC} -name Makefile \
- |${XARGS} -n 1 ${REINPLACE_CMD} -e 's|-O2||g'
+#post-configure::
+# ${FIND} ${WRKSRC} -name Makefile \
+# |${XARGS} -n 1 ${REINPLACE_CMD} -e 's|-O2||g'
.include <bsd.port.mk>