aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 09:30:55 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 09:30:55 +0800
commitadb4fcf7201084dd01af1bd46f4bd2f250c8fa83 (patch)
treea27a571b1ad10da59296f48f79c8a4f5c3f1fb0a /print/scribus
parentce9946f271a9c77c89338a55a7c4b675c46162c1 (diff)
downloadfreebsd-ports-gnome-adb4fcf7201084dd01af1bd46f4bd2f250c8fa83.tar.gz
freebsd-ports-gnome-adb4fcf7201084dd01af1bd46f4bd2f250c8fa83.tar.zst
freebsd-ports-gnome-adb4fcf7201084dd01af1bd46f4bd2f250c8fa83.zip
[PATCH] print/scribus: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afpl PR: ports/54961 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'print/scribus')
-rw-r--r--print/scribus/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index f3baa21f9070..179829416d02 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -15,8 +15,14 @@ MASTER_SITES= http://web2.altmuehlnet.de/fschmid/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A comprehensive desktop publishing program
+.if defined(WITH_GHOSTSCRIPT_AFP1) && ${WITH_GHOSTSCRIPT_AFP1} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
USE_QT_VER= 3
USE_REINPLACE= yes
@@ -29,6 +35,14 @@ LDCONFIG_DIRS= %%PREFIX%%/lib/scribus/libs \
QTCFGLIBS+= -lm
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure