aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-26 20:31:15 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-26 20:31:15 +0800
commitadf2eb36c7d08f43dd88e76a7880775318a7951f (patch)
tree02ceb59e2898d11fdcfad3463a41b7d277a70ea4 /print/scribus
parent2ee7696b62245fc8b2c47b32dd5d2b072d9a129a (diff)
downloadfreebsd-ports-gnome-adf2eb36c7d08f43dd88e76a7880775318a7951f.tar.gz
freebsd-ports-gnome-adf2eb36c7d08f43dd88e76a7880775318a7951f.tar.zst
freebsd-ports-gnome-adf2eb36c7d08f43dd88e76a7880775318a7951f.zip
print/scribus: unbreak with hunspell 1.5
-- Could NOT find HUNSPELL (missing: HUNSPELL_LIBRARIES) HunSpell or its developer libraries NOT found - Disabling support for spell checking [...] ===> Checking for items in pkg-plist which are not in STAGEDIR Error: Missing: lib/scribus/plugins/libhunspellplugin.so scribus/plugins/tools/hunspellcheck/hunspelldict.cpp:22:9: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char* dictEncoding = m_hunspell->get_dic_encoding(); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ https://github.com/hunspell/hunspell/commit/971f8a9cf52e PR: 214837 Approved by: portmgr blanket
Diffstat (limited to 'print/scribus')
-rw-r--r--print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake12
-rw-r--r--print/scribus/files/patch-scribus_plugins_tools_hunspellcheck_hunspelldict.cpp11
2 files changed, 23 insertions, 0 deletions
diff --git a/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake b/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake
new file mode 100644
index 000000000000..99800ad9f7ef
--- /dev/null
+++ b/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake
@@ -0,0 +1,12 @@
+--- cmake/modules/FindHUNSPELL.cmake.orig 2012-04-10 20:15:53 UTC
++++ cmake/modules/FindHUNSPELL.cmake
+@@ -9,7 +9,8 @@
+ #Based on examples at http://www.vtk.org/Wiki/CMake:How_To_Find_Libraries
+
+ FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx )
+-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.3 hunspell-1.2 PATHS /opt/local/lib /usr/local/lib /usr/lib )
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2
++ PATHS /opt/local/lib /usr/local/lib /usr/lib )
+
+ INCLUDE(FindPackageHandleStandardArgs)
+ # handle the QUIETLY and REQUIRED arguments and set HUNSPELL_FOUND to TRUE
diff --git a/print/scribus/files/patch-scribus_plugins_tools_hunspellcheck_hunspelldict.cpp b/print/scribus/files/patch-scribus_plugins_tools_hunspellcheck_hunspelldict.cpp
new file mode 100644
index 000000000000..fddcc1ea23a0
--- /dev/null
+++ b/print/scribus/files/patch-scribus_plugins_tools_hunspellcheck_hunspelldict.cpp
@@ -0,0 +1,11 @@
+--- scribus/plugins/tools/hunspellcheck/hunspelldict.cpp.orig 2012-11-20 22:49:14 UTC
++++ scribus/plugins/tools/hunspellcheck/hunspelldict.cpp
+@@ -19,7 +19,7 @@ HunspellDict::HunspellDict(const QString
+ m_hunspell = new Hunspell(affPath.toLocal8Bit().constData(), dictPath.toLocal8Bit().constData());
+ if (m_hunspell)
+ {
+- char* dictEncoding = m_hunspell->get_dic_encoding();
++ const char* dictEncoding = m_hunspell->get_dic_encoding();
+ if (dictEncoding)
+ encoding = QString::fromLatin1(dictEncoding);
+ }