aboutsummaryrefslogtreecommitdiffstats
path: root/print/tex-ptexenc
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-07-26 05:36:56 +0800
committerhrs <hrs@FreeBSD.org>2015-07-26 05:36:56 +0800
commit02eab264a708570887db44f02a8e6015a90fec1c (patch)
treebbcce3615eaf675f612d54cb21b7d4fc41b80d57 /print/tex-ptexenc
parent277c1440066b5a936766ac0d3734a8a8ac55be69 (diff)
downloadfreebsd-ports-gnome-02eab264a708570887db44f02a8e6015a90fec1c.tar.gz
freebsd-ports-gnome-02eab264a708570887db44f02a8e6015a90fec1c.tar.zst
freebsd-ports-gnome-02eab264a708570887db44f02a8e6015a90fec1c.zip
- Add iconv support.
- Add LICENSE. - Add CTAN mirror to MASTER_SITES.
Diffstat (limited to 'print/tex-ptexenc')
-rw-r--r--print/tex-ptexenc/Makefile19
-rw-r--r--print/tex-ptexenc/files/patch-configure38
2 files changed, 50 insertions, 7 deletions
diff --git a/print/tex-ptexenc/Makefile b/print/tex-ptexenc/Makefile
index 15b5abdba3ff..7be070b9d68d 100644
--- a/print/tex-ptexenc/Makefile
+++ b/print/tex-ptexenc/Makefile
@@ -2,9 +2,9 @@
PORTNAME= ptexenc
PORTVERSION= 1.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
-MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
+MASTER_SITES= TEX_CTAN/systems/texlive/Source/
PKGNAMEPREFIX= tex-
DISTNAME= texlive-20150521-source
DIST_SUBDIR= TeX
@@ -12,17 +12,22 @@ DIST_SUBDIR= TeX
MAINTAINER= hrs@FreeBSD.org
COMMENT= Library for Japanese pTeX and its tools
-USES= tar:xz libtool pkgconfig
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USES= iconv libtool pkgconfig tar:xz
USE_TEX= kpathsea
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/texk/ptexenc
-EXTRACT_AFTER_ARGS= ${EXTRACT_FILES}
-EXTRACT_FILES= ${DISTNAME}/build-aux \
- ${DISTNAME}/texk/ptexenc
+EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S/^/${DISTNAME}\//}
+EXTRACT_FILES= build-aux texk/ptexenc
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-system-kpathsea \
+CONFIGURE_ARGS= --enable-kanji-iconv \
+ --with-system-kpathsea \
--with-kpathsea-includes=${LOCALBASE}/include \
--with-kpathsea-libdir=${LOCALBASE}/lib
+LIBS+= ${ICONV_LIB}
+CPPFLAGS+= -I${ICONV_PREFIX}/include
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/print/tex-ptexenc/files/patch-configure b/print/tex-ptexenc/files/patch-configure
new file mode 100644
index 000000000000..e295021adb53
--- /dev/null
+++ b/print/tex-ptexenc/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig 2015-07-25 21:31:25 UTC
++++ configure
+@@ -14889,7 +14889,7 @@ if ${ac_cv_lib_iconv_iconv_open+:} false
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-liconv $LIBS"
++LIBS="$LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -14924,7 +14924,7 @@ if test "x$ac_cv_lib_iconv_iconv_open" =
+ #define HAVE_LIBICONV 1
+ _ACEOF
+
+- LIBS="-liconv $LIBS"
++ LIBS="$LIBS"
+
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libiconv_open in -liconv" >&5
+@@ -14933,7 +14933,7 @@ if ${ac_cv_lib_iconv_libiconv_open+:} fa
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-liconv $LIBS"
++LIBS="$LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -14968,7 +14968,7 @@ if test "x$ac_cv_lib_iconv_libiconv_open
+ #define HAVE_LIBICONV 1
+ _ACEOF
+
+- LIBS="-liconv $LIBS"
++ LIBS="$LIBS"
+
+ fi
+