aboutsummaryrefslogtreecommitdiffstats
path: root/print/tex-xdvik/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-01-31 20:48:14 +0800
committerhrs <hrs@FreeBSD.org>2015-01-31 20:48:14 +0800
commitd62d8452cd08201bffa435ecb9043943ceff8540 (patch)
treea405788599bab9ad7365316e1484954d9d847f81 /print/tex-xdvik/Makefile
parent857f5f3ee8ca698eee634b47c0eea76ccbc5e6aa (diff)
downloadfreebsd-ports-gnome-d62d8452cd08201bffa435ecb9043943ceff8540.tar.gz
freebsd-ports-gnome-d62d8452cd08201bffa435ecb9043943ceff8540.tar.zst
freebsd-ports-gnome-d62d8452cd08201bffa435ecb9043943ceff8540.zip
- Add pTeX support to xdvik. This improvement is imported from
the latest j1.42 patchset by adjusting it to the 22.87 code base. - Move files in TEXMFDISTDIR/xdvi to TEXMFDISTDIR/dvips/xdvi.
Diffstat (limited to 'print/tex-xdvik/Makefile')
-rw-r--r--print/tex-xdvik/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/print/tex-xdvik/Makefile b/print/tex-xdvik/Makefile
index 5b91740e81d0..9f88c76d7025 100644
--- a/print/tex-xdvik/Makefile
+++ b/print/tex-xdvik/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xdvik
PORTVERSION= 22.87
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= SF/xdvi/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= tex-
@@ -14,12 +14,14 @@ COMMENT= DVI Previewer(kpathsearch) for X
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libpaper.so:${PORTSDIR}/print/libpaper
+RUN_DEPENDS= tex-dvipsk>=5.994_1:${PORTSDIR}/print/tex-dvipsk
USES= iconv gmake motif
USE_TEX= web2c kpathsea texmf texhash
TEXHASHDIRS= ${TEXMFDISTDIR}
USE_XORG= ice sm x11 xmu xpm xt xi
WRKSRC= ${WRKDIR}/${DISTNAME}/texk/xdvik
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
--datarootdir=${LOCALBASE}/share \
@@ -52,8 +54,11 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/xdvi
+ ${INSTALL_DATA} ${WRKSRC}/xdvi-ptex.map \
+ ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/xdvi/xdvi-ptex.map
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKDIR}/${DISTNAME} && \
${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}