aboutsummaryrefslogtreecommitdiffstats
path: root/print/texinfo/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-05-31 07:23:29 +0800
committerlioux <lioux@FreeBSD.org>2005-05-31 07:23:29 +0800
commit70e811c5020adb8dcbfec6e5e5ff043471888409 (patch)
tree1862460fd5ec1701d6208b6377e83dc9f94df7a0 /print/texinfo/Makefile
parent9db9895f51317ef488cb21a29b744d91b6c6dad0 (diff)
downloadfreebsd-ports-gnome-70e811c5020adb8dcbfec6e5e5ff043471888409.tar.gz
freebsd-ports-gnome-70e811c5020adb8dcbfec6e5e5ff043471888409.tar.zst
freebsd-ports-gnome-70e811c5020adb8dcbfec6e5e5ff043471888409.zip
New port print/texinfo version 4.8: A typeset documentation system
with multiple format output
Diffstat (limited to 'print/texinfo/Makefile')
-rw-r--r--print/texinfo/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
new file mode 100644
index 000000000000..5b50758cc05b
--- /dev/null
+++ b/print/texinfo/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: latest texinfo
+# Date created: Sun May 29 17:32:08 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= texinfo
+PORTVERSION= 4.8
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A typeset documentation system with multiple format output
+
+USE_GETTEXT= yes
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALL_TARGET= install install-tex
+PKGDEINSTALL= ${PKGINSTALL}
+
+MAKE_ARGS= TEXMF=${PREFIX}/${TEXMFLOCAL}
+CONFIGURE_ARGS= \
+ --infodir=${PREFIX}/${INFO_PATH} \
+ --without-included-gettext
+CONFIGURE_ENV= \
+ CPPFLAGS="-I${LOCALBASE}/lib" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+INFO= ${PORTNAME} info-stnd info
+MAN1= info.1 infokey.1 install-info.1 makeinfo.1 texi2dvi.1 \
+ texindex.1
+MAN5= info.5 texinfo.5
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL}
+
+TEXMFLOCAL= share/texmf-local
+
+post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>