aboutsummaryrefslogtreecommitdiffstats
path: root/print/tgif2tex/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2008-05-31 17:35:15 +0800
committerhrs <hrs@FreeBSD.org>2008-05-31 17:35:15 +0800
commit93c83ebf8bb230f9c3b940febd1921039c5139b1 (patch)
tree68797adf02fa0050f9eed71ad6ab2120dd95c0e4 /print/tgif2tex/Makefile
parent8d6815a62cc8795585539644020257655da2e1ca (diff)
downloadfreebsd-ports-gnome-93c83ebf8bb230f9c3b940febd1921039c5139b1.tar.gz
freebsd-ports-gnome-93c83ebf8bb230f9c3b940febd1921039c5139b1.tar.zst
freebsd-ports-gnome-93c83ebf8bb230f9c3b940febd1921039c5139b1.zip
- Use $PLIST_FILES and $PORTDOCS to simplify the port.
- Remove 00readme. - Remove a duplicated line in patch-tgif2tex. - Add s,#!/usr/bin/perl,${PERL}, replacement.
Diffstat (limited to 'print/tgif2tex/Makefile')
-rw-r--r--print/tgif2tex/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/print/tgif2tex/Makefile b/print/tgif2tex/Makefile
index 0b5d81bc955c..2f8c600d9934 100644
--- a/print/tgif2tex/Makefile
+++ b/print/tgif2tex/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tgif2tex
PORTVERSION= 2.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= print
MASTER_SITES= http://www.cs.hiroshima-u.ac.jp/~nakano/tgif2tex/
@@ -16,7 +16,8 @@ COMMENT= Converting texts in figure by tgif to LaTeX commands
USE_PERL5_RUN= yes
-DOCSRC= how-to-use.aux how-to-use.dvi \
+PLIST_FILES= bin/tgif2tex
+PORTDOCS= how-to-use.aux how-to-use.dvi \
how-to-use.log how-to-use.ps how-to-use.tex \
example.obj example.tex \
original.dps original.tps \
@@ -31,14 +32,14 @@ DOCSRC= how-to-use.aux how-to-use.dvi \
do-build:
${REINPLACE_CMD} \
-e "s,%%LOCALBASE%%,${LOCALBASE}," \
+ -e "s,^#!/usr/bin/perl,#!${PERL}," \
${WRKSRC}/tgif2tex
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/tgif2tex ${PREFIX}/bin/tgif2tex
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}; ${INSTALL_DATA} ${DOCSRC} ${DOCSDIR};
- ${INSTALL_DATA} ${FILESDIR}/00readme ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>