aboutsummaryrefslogtreecommitdiffstats
path: root/print/xfce4-print
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-04-14 06:08:04 +0800
committeroliver <oliver@FreeBSD.org>2005-04-14 06:08:04 +0800
commit1a6fe332419348d8cc1e50c3fb0625683c3b79d3 (patch)
tree9991e9dfa5aa17999199843c497bad78708b8e18 /print/xfce4-print
parentb2e24606a2f7f55ba4bc198f18d64bebf9c1a04d (diff)
downloadfreebsd-ports-gnome-1a6fe332419348d8cc1e50c3fb0625683c3b79d3.tar.gz
freebsd-ports-gnome-1a6fe332419348d8cc1e50c3fb0625683c3b79d3.tar.zst
freebsd-ports-gnome-1a6fe332419348d8cc1e50c3fb0625683c3b79d3.zip
- make xfprint work
o it will tell you now that you have to configure it first using the Xfce settings manager instead of coredumping o if you configured it, it will work now (-Wl,-E was missing in LDFLAGS) - bump PORTREVISION
Diffstat (limited to 'print/xfce4-print')
-rw-r--r--print/xfce4-print/Makefile9
-rw-r--r--print/xfce4-print/files/patch-xfprint-manager::main.c33
-rw-r--r--print/xfce4-print/files/patch-xfprint::main.c33
3 files changed, 73 insertions, 2 deletions
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index a1dd18948125..36443084d8b2 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-print
PORTVERSION= 4.2.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= print xfce
MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://www.ca-us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
@@ -29,6 +29,7 @@ USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
@@ -50,7 +51,7 @@ PLIST_SUB+= CUPS="@comment "
CONFIGURE_ARGS+=--disable-bsdlpr
PLIST_SUB+= LPR="@comment "
.else
-CONFIGURE_ARGS+=--enable-bsdlpr
+CONFIGURE_ARGS+=--enable-bsdlpr --with-printcap=/etc/printcap
PLIST_SUB+= LPR=""
.endif
@@ -64,4 +65,8 @@ BUILD_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-a4
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-a4
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's/@LDFLAGS@/& -Wl,-E/' ${WRKSRC}/xfprint/Makefile.in \
+ ${WRKSRC}/xfprint-manager/Makefile.in
+
.include <bsd.port.mk>
diff --git a/print/xfce4-print/files/patch-xfprint-manager::main.c b/print/xfce4-print/files/patch-xfprint-manager::main.c
new file mode 100644
index 000000000000..33c55a70fe77
--- /dev/null
+++ b/print/xfce4-print/files/patch-xfprint-manager::main.c
@@ -0,0 +1,33 @@
+--- xfprint-manager/main.c.orig Wed Apr 13 23:56:53 2005
++++ xfprint-manager/main.c Wed Apr 13 23:55:57 2005
+@@ -101,22 +101,17 @@
+ mcs_client_add_channel (client, CHANNEL);
+
+ if (mcs_client_get_setting (client, "XfPrint/system", CHANNEL, &setting) == MCS_SUCCESS) {
+- if (!load_printing_system (setting->data.v_string))
+- g_error ("Unable to load printing system module %s", setting->data.v_string);
++ if (!load_printing_system (setting->data.v_string) && strncmp(setting->data.v_string,"file_plugin.so",14) == 0) {
++ g_print ("Configure your printing system using the Xfce Settings Manager first\n");
++ exit (EXIT_FAILURE);
++ } else if (!load_printing_system (setting->data.v_string) ) {
++ g_error ("Unable to load printing system module %s", setting->data.v_string);
++ }
+ mcs_setting_free (setting);
+ }
+ else {
+- gchar *default_system = NULL;
+-
+- g_warning ("No mcs-setting found for XfPrint/system in channel %s, using default printing-system", CHANNEL);
+-
+- default_system = g_build_filename (PLUGIN_DIR, "file_plugin.so", NULL);
+-
+- if (!load_printing_system (default_system)) {
+- g_error ("Unable to load default printing system module %s", default_system);
+- }
+-
+- g_free (default_system);
++ g_print ("Configure your printing system using the Xfce Settings Manager first\n");
++ exit (EXIT_FAILURE);
+ }
+
+ mcs_client_destroy (client);
diff --git a/print/xfce4-print/files/patch-xfprint::main.c b/print/xfce4-print/files/patch-xfprint::main.c
new file mode 100644
index 000000000000..900a89423c5f
--- /dev/null
+++ b/print/xfce4-print/files/patch-xfprint::main.c
@@ -0,0 +1,33 @@
+--- xfprint/main.c.orig Wed Apr 13 23:55:06 2005
++++ xfprint/main.c Wed Apr 13 23:55:07 2005
+@@ -87,22 +87,17 @@
+ mcs_client_add_channel (client, CHANNEL);
+
+ if (mcs_client_get_setting (client, "XfPrint/system", CHANNEL, &setting) == MCS_SUCCESS) {
+- if (!load_printing_system (setting->data.v_string))
+- g_error ("Unable to load printing system module %s", setting->data.v_string);
++ if (!load_printing_system (setting->data.v_string) && strncmp(setting->data.v_string,"file_plugin.so",14) == 0) {
++ g_print ("Configure your printing system using the Xfce Settings Manager first\n");
++ exit (EXIT_FAILURE);
++ } else if (!load_printing_system (setting->data.v_string) ) {
++ g_error ("Unable to load printing system module %s", setting->data.v_string);
++ }
+ mcs_setting_free (setting);
+ }
+ else {
+- gchar *default_system = NULL;
+-
+- g_warning ("No mcs-setting found for XfPrint/system in channel %s, using default printing-system", CHANNEL);
+-
+- default_system = g_build_filename (PLUGIN_DIR, "file_plugin.so", NULL);
+-
+- if (!load_printing_system (default_system)) {
+- g_error ("Unable to load default printing system module %s", default_system);
+- }
+-
+- g_free (default_system);
++ g_print ("Configure your printing system using the Xfce Settings Manager first\n");
++ exit (EXIT_FAILURE);
+ }
+
+ mcs_client_destroy (client);