aboutsummaryrefslogtreecommitdiffstats
path: root/print/xpp
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2011-11-30 05:15:20 +0800
committercy <cy@FreeBSD.org>2011-11-30 05:15:20 +0800
commitd7981e412d00411d9fc30060344ffde9d0649f98 (patch)
tree631d4f6b8ca9955173e44affa4bba9beec57bb2b /print/xpp
parentb0f1830dd820e2e78b70d44482ddb93c450ea785 (diff)
downloadfreebsd-ports-gnome-d7981e412d00411d9fc30060344ffde9d0649f98.tar.gz
freebsd-ports-gnome-d7981e412d00411d9fc30060344ffde9d0649f98.tar.zst
freebsd-ports-gnome-d7981e412d00411d9fc30060344ffde9d0649f98.zip
Fix build errors due to cups 1.5.0.
Assume maintainership of this orphan. Feature safe: yes
Diffstat (limited to 'print/xpp')
-rw-r--r--print/xpp/Makefile7
-rw-r--r--print/xpp/files/patch-cupshelper.h10
-rw-r--r--print/xpp/files/patch-xpp.h10
3 files changed, 22 insertions, 5 deletions
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
index 21ea4499569e..472085530c1c 100644
--- a/print/xpp/Makefile
+++ b/print/xpp/Makefile
@@ -7,20 +7,17 @@
PORTNAME= xpp
PORTVERSION= 1.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= print
MASTER_SITES= SF/cups/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= X11-based printer manager for CUPS
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
BUILD_DEPENDS= ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
-BROKEN= does not compile
-EXPIRATION_DATE= 2011-11-30
-
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/print/xpp/files/patch-cupshelper.h b/print/xpp/files/patch-cupshelper.h
new file mode 100644
index 000000000000..3e4d2052b903
--- /dev/null
+++ b/print/xpp/files/patch-cupshelper.h
@@ -0,0 +1,10 @@
+--- cupshelper.h.orig 2002-05-28 08:49:45.000000000 -0700
++++ cupshelper.h 2011-11-29 13:10:22.991997261 -0800
+@@ -34,6 +34,7 @@
+ #define CUPSHELPER_H
+
+ #include <cups/cups.h>
++#include <cups/ppd.h>
+ #include <cups/ipp.h>
+
+ const char* cupsGetPassword(const char *prompt);
diff --git a/print/xpp/files/patch-xpp.h b/print/xpp/files/patch-xpp.h
new file mode 100644
index 000000000000..94a77814e6a7
--- /dev/null
+++ b/print/xpp/files/patch-xpp.h
@@ -0,0 +1,10 @@
+--- xpp.h.orig 2011-11-29 13:02:26.198230347 -0800
++++ xpp.h 2011-11-29 13:07:43.783229272 -0800
+@@ -34,6 +34,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <cups/cups.h>
++#include <cups/ppd.h>
+ #include <cups/ipp.h>
+ #include <cups/language.h>
+ #include <FL/Fl.H>