aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-08-13 02:15:48 +0800
committerjkim <jkim@FreeBSD.org>2015-08-13 02:15:48 +0800
commit352a15eafc780b76cc437cf8057541f1e67368a4 (patch)
treed97f218f086a82c721e34cdb8bd77574b5b042bb /print
parent479244e71dacfb1921e5d67396477ca111dbc65e (diff)
downloadfreebsd-ports-gnome-352a15eafc780b76cc437cf8057541f1e67368a4.tar.gz
freebsd-ports-gnome-352a15eafc780b76cc437cf8057541f1e67368a4.tar.zst
freebsd-ports-gnome-352a15eafc780b76cc437cf8057541f1e67368a4.zip
Libpagemaker is a library that parses the file format of Aldus/Adobe
PageMaker documents. WWW: https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/libpagemaker/Makefile24
-rw-r--r--print/libpagemaker/distinfo2
-rw-r--r--print/libpagemaker/pkg-descr4
-rw-r--r--print/libpagemaker/pkg-plist8
5 files changed, 39 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index cea804fe5706..3a6b858864d2 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -119,6 +119,7 @@
SUBDIR += libijs
SUBDIR += libmspub01
SUBDIR += libotf
+ SUBDIR += libpagemaker
SUBDIR += libpaper
SUBDIR += libppd
SUBDIR += libspectre
diff --git a/print/libpagemaker/Makefile b/print/libpagemaker/Makefile
new file mode 100644
index 000000000000..c7b9b7107b6d
--- /dev/null
+++ b/print/libpagemaker/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= libpagemaker
+PORTVERSION= 0.0.2
+CATEGORIES= print graphics devel
+MASTER_SITES= LIBREOFFICE_DEV
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library and tools for parsing Aldus/Adobe PageMaker documents
+
+LICENSE= MPL
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/format.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= librevenge-0.0.so:${PORTSDIR}/textproc/librevenge
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= libtool pathfix pkgconfig tar:xz
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS= --disable-werror --without-docs
+CPPFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/print/libpagemaker/distinfo b/print/libpagemaker/distinfo
new file mode 100644
index 000000000000..e11bb3040ff9
--- /dev/null
+++ b/print/libpagemaker/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libpagemaker-0.0.2.tar.xz) = cdbdf86605773339caab6477ff694a95a90aaa4d45bb6cdb59e4a7f76c91ef17
+SIZE (libpagemaker-0.0.2.tar.xz) = 279396
diff --git a/print/libpagemaker/pkg-descr b/print/libpagemaker/pkg-descr
new file mode 100644
index 000000000000..64cdba7092fd
--- /dev/null
+++ b/print/libpagemaker/pkg-descr
@@ -0,0 +1,4 @@
+Libpagemaker is a library that parses the file format of Aldus/Adobe
+PageMaker documents.
+
+WWW: https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker
diff --git a/print/libpagemaker/pkg-plist b/print/libpagemaker/pkg-plist
new file mode 100644
index 000000000000..ec7ce25d16c3
--- /dev/null
+++ b/print/libpagemaker/pkg-plist
@@ -0,0 +1,8 @@
+bin/pmd2raw
+bin/pmd2svg
+include/libpagemaker-0.0/libpagemaker/PMDocument.h
+include/libpagemaker-0.0/libpagemaker/libpagemaker.h
+lib/libpagemaker-0.0.so
+lib/libpagemaker-0.0.so.0
+lib/libpagemaker-0.0.so.0.0.2
+libdata/pkgconfig/libpagemaker-0.0.pc