aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-29 22:19:09 +0800
committertijl <tijl@FreeBSD.org>2016-03-29 22:19:09 +0800
commit9589899816cf55c587ac8c8b75064365d8a204ac (patch)
tree1d6b820a49017324ec70826849a8abb45096793b /print
parente1a8ca46cedbe7986fb570a518a886a171fd57ee (diff)
downloadfreebsd-ports-gnome-9589899816cf55c587ac8c8b75064365d8a204ac.tar.gz
freebsd-ports-gnome-9589899816cf55c587ac8c8b75064365d8a204ac.tar.zst
freebsd-ports-gnome-9589899816cf55c587ac8c8b75064365d8a204ac.zip
- Update cups-filters to 1.8.3.
- Move D-Bus dependency under a COLORD option. - Make libijs dependency optional. - Add BRAILLE option and add missing dependencies to it. There's no port of liblouisutdml yet but it isn't strictly required. - Move jpeg, png and tiff dependencies under an IMAGEFILTERS option. - Add an option group for cups-browsed, move AVAHI under it and add LDAP. - Add an option group to select the default PDF-to-PostScript renderer. - Add --disable-silent-rules to CONFIGURE_ARGS to make build logs more verbose. PR: 208345 Approved by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile89
-rw-r--r--print/cups-filters/distinfo4
-rw-r--r--print/cups-filters/pkg-plist65
3 files changed, 103 insertions, 55 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index eb65e0b0e2b4..e962b909ffba 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -1,22 +1,15 @@
# $FreeBSD$
PORTNAME= cups-filters
-PORTVERSION= 1.8.2
-PORTREVISION= 5
+PORTVERSION= 1.8.3
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
MAINTAINER= cyberbotx@cyberbotx.com
-COMMENT= Backends, filters and other software (was part of the core CUPS)
-
-BUILD_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
-RUN_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
-LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
- libpng.so:${PORTSDIR}/graphics/png \
- libijs.so:${PORTSDIR}/print/libijs \
- liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+COMMENT= Additional backends, filters and other software for CUPS
+
+LIB_DEPENDS= liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libqpdf.so:${PORTSDIR}/print/qpdf \
- libdbus-1.so:${PORTSDIR}/devel/dbus \
libcupsimage.so:${PORTSDIR}/print/cups \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
@@ -24,7 +17,7 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
CONFLICTS= cups-pstoraster-[0-9]* foomatic-filters-[0-9]*
-USES= compiler:c++11-lib cpe ghostscript gmake jpeg libtool pathfix \
+USES= compiler:c++11-lib cpe ghostscript gmake gnome libtool pathfix \
pkgconfig shebangfix tar:xz
CPE_VENDOR= linuxfoundation
SHEBANG_FILES= filter/braille/drivers/generic/brftoembosser.in \
@@ -36,25 +29,79 @@ SHEBANG_FILES= filter/braille/drivers/generic/brftoembosser.in \
USE_GNOME= glib20
USE_RC_SUBR= cups_browsed
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-shell=/bin/sh ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
+CONFIGURE_ARGS= --disable-silent-rules --with-shell=/bin/sh \
+ ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-OPTIONS_DEFINE= AVAHI DOCS
-OPTIONS_DEFAULT=AVAHI
+OPTIONS_DEFINE= BRAILLE COLORD DOCS IJS IMAGEFILTERS
+OPTIONS_GROUP= CUPS_BROWSED
+OPTIONS_GROUP_CUPS_BROWSED= AVAHI LDAP
+OPTIONS_SINGLE= PDFTOPS_RENDERER
+OPTIONS_SINGLE_PDFTOPS_RENDERER=GS HYBRID PDFTOPS
+OPTIONS_DEFAULT= AVAHI COLORD HYBRID IJS IMAGEFILTERS
+OPTIONS_SUB= yes
+
+BRAILLE_CONFIGURE_ENABLE= braille
+BRAILLE_DESC= Braille embosser support
+BRAILLE_LIB_DEPENDS= liblouis.so:${PORTSDIR}/devel/liblouis \
+# liblouisutdml.so:${PORTSDIR}/devel/liblouisutdml
+BRAILLE_RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ pdftotext:${PORTSDIR}/graphics/poppler-utils \
+ bash:${PORTSDIR}/shells/bash
+
+COLORD_CONFIGURE_ENABLE= dbus
+COLORD_DESC= Get ICC color profiles from colord (via D-Bus)
+COLORD_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+COLORD_RUN_DEPENDS= colord>0:${PORTSDIR}/graphics/colord
+
+IJS_CONFIGURE_ENABLE= ijs
+IJS_DESC= Support PPD files that use pdftoijs
+IJS_LIB_DEPENDS= libijs.so:${PORTSDIR}/print/libijs
+
+IMAGEFILTERS_CONFIGURE_ENABLE= imagefilters
+IMAGEFILTERS_CONFIGURE_WITH= jpeg png tiff
+IMAGEFILTERS_DESC= Support printing image files
+IMAGEFILTERS_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+ libpng.so:${PORTSDIR}/graphics/png
+IMAGEFILTERS_USES= jpeg
+
+# cups-browsed(8) options
+
+AVAHI_CONFIGURE_ENABLE= avahi
+AVAHI_CONFIGURE_OFF= --with-browseremoteprotocols=cups
+AVAHI_CONFIGURE_ON= --with-browseremoteprotocols="dnssd cups"
+AVAHI_LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app
+AVAHI_SUB_LIST= AVAHI_DAEMON=avahi_daemon
+AVAHI_SUB_LIST_OFF= AVAHI_DAEMON=
+
+CUPS_BROWSED_DESC= cups-browsed(8) options
+
+LDAP_CONFIGURE_ENABLE= ldap
+LDAP_USE= OPENLDAP=yes
+
+# Default PDF-to-PostScript renderer
+
+GS_CONFIGURE_ON= --with-pdftops=gs
+GS_DESC= Ghostscript gs(1)
+
+HYBRID_BUILD_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
+HYBRID_RUN_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
+HYBRID_CONFIGURE_ON= --with-pdftops=hybrid
+HYBRID_DESC= Ghostscript or Poppler depending on printer
+
+PDFTOPS_BUILD_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
+PDFTOPS_RUN_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
+PDFTOPS_CONFIGURE_ON= --with-pdftops=pdftops
+PDFTOPS_DESC= Poppler pdftops(1)
-AVAHI_CONFIGURE_ENABLE= avahi
-AVAHI_LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app
-AVAHI_SUB_LIST= AVAHI_DAEMON=avahi_daemon
-AVAHI_SUB_LIST_OFF= AVAHI_DAEMON=
+PDFTOPS_RENDERER_DESC= Default PDF-to-PostScript renderer
post-patch:
@${REINPLACE_CMD} 's:-std=c++0x:-std=c++11:' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} 's|/usr/share/liblouis|${LOCALBASE}/share/liblouis|' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
-e 's|README.gz|README|' \
${WRKSRC}/utils/cups-browsed.8 \
diff --git a/print/cups-filters/distinfo b/print/cups-filters/distinfo
index bdcb78d69451..d9ec96fd6e85 100644
--- a/print/cups-filters/distinfo
+++ b/print/cups-filters/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-filters-1.8.2.tar.xz) = 06d1c2a65e45d92d0e2dc854d13161d01072094efe4fadc23319700c9a259c69
-SIZE (cups-filters-1.8.2.tar.xz) = 1372508
+SHA256 (cups-filters-1.8.3.tar.xz) = e1e786f1fbcd3a203d87ebb4106a0ba8d579953cbe22056d12d4ee8143f5341a
+SIZE (cups-filters-1.8.3.tar.xz) = 1373028
diff --git a/print/cups-filters/pkg-plist b/print/cups-filters/pkg-plist
index 42c815c29557..bf3e9ea0917b 100644
--- a/print/cups-filters/pkg-plist
+++ b/print/cups-filters/pkg-plist
@@ -27,20 +27,20 @@ libexec/cups/backend/implicitclass
libexec/cups/backend/parallel
libexec/cups/backend/serial
libexec/cups/filter/bannertopdf
-libexec/cups/filter/brftoembosser
+%%BRAILLE%%libexec/cups/filter/brftoembosser
libexec/cups/filter/commandtoescpx
libexec/cups/filter/commandtopclx
libexec/cups/filter/foomatic-rip
libexec/cups/filter/gstopxl
libexec/cups/filter/gstoraster
-libexec/cups/filter/imagetobrf
-libexec/cups/filter/imagetopdf
-libexec/cups/filter/imagetops
-libexec/cups/filter/imagetoraster
-libexec/cups/filter/imagetoubrl
-libexec/cups/filter/imageubrltoindexv3
-libexec/cups/filter/imageubrltoindexv4
-libexec/cups/filter/pdftoijs
+%%BRAILLE%%libexec/cups/filter/imagetobrf
+%%IMAGEFILTERS%%libexec/cups/filter/imagetopdf
+%%IMAGEFILTERS%%libexec/cups/filter/imagetops
+%%IMAGEFILTERS%%libexec/cups/filter/imagetoraster
+%%BRAILLE%%libexec/cups/filter/imagetoubrl
+%%BRAILLE%%libexec/cups/filter/imageubrltoindexv3
+%%BRAILLE%%libexec/cups/filter/imageubrltoindexv4
+%%IJS%%libexec/cups/filter/pdftoijs
libexec/cups/filter/pdftoopvp
libexec/cups/filter/pdftopdf
libexec/cups/filter/pdftops
@@ -50,10 +50,10 @@ libexec/cups/filter/rastertoescpx
libexec/cups/filter/rastertopclx
libexec/cups/filter/rastertopdf
libexec/cups/filter/sys5ippprinter
-libexec/cups/filter/textbrftoindexv3
-libexec/cups/filter/textbrftoindexv4
+%%BRAILLE%%libexec/cups/filter/textbrftoindexv3
+%%BRAILLE%%libexec/cups/filter/textbrftoindexv4
libexec/cups/filter/textonly
-libexec/cups/filter/texttobrf
+%%BRAILLE%%libexec/cups/filter/texttobrf
libexec/cups/filter/texttopdf
libexec/cups/filter/texttops
libexec/cups/filter/urftopdf
@@ -68,10 +68,10 @@ share/cups/banners/secret
share/cups/banners/standard
share/cups/banners/topsecret
share/cups/banners/unclassified
-share/cups/braille/cups-braille.sh
-share/cups/braille/index.sh
-share/cups/braille/indexv3.sh
-share/cups/braille/indexv4.sh
+%%BRAILLE%%share/cups/braille/cups-braille.sh
+%%BRAILLE%%share/cups/braille/index.sh
+%%BRAILLE%%share/cups/braille/indexv3.sh
+%%BRAILLE%%share/cups/braille/indexv4.sh
share/cups/charsets/pdf.utf-8
share/cups/charsets/pdf.utf-8.heavy
share/cups/charsets/pdf.utf-8.simple
@@ -89,24 +89,25 @@ share/cups/data/testprint
share/cups/data/topsecret.pdf
share/cups/data/unclassified.pdf
share/cups/drv/cupsfilters.drv
-share/cups/drv/generic-brf.drv
-share/cups/drv/indexv3.drv
-share/cups/drv/indexv4.drv
-share/cups/mime/braille.convs
-share/cups/mime/braille.types
+%%BRAILLE%%share/cups/drv/generic-brf.drv
+%%BRAILLE%%share/cups/drv/indexv3.drv
+%%BRAILLE%%share/cups/drv/indexv4.drv
+%%BRAILLE%%share/cups/mime/braille.convs
+%%BRAILLE%%share/cups/mime/braille.types
+share/cups/mime/cupsfilters-ghostscript.convs
share/cups/mime/cupsfilters.convs
share/cups/mime/cupsfilters.types
-share/cups/ppdc/braille.defs
+%%BRAILLE%%share/cups/ppdc/braille.defs
share/cups/ppdc/escp.h
-share/cups/ppdc/fr-braille.po
-share/cups/ppdc/imagemagick.defs
-share/cups/ppdc/index.defs
-share/cups/ppdc/liblouis.defs
-share/cups/ppdc/liblouis1.defs
-share/cups/ppdc/liblouis2.defs
-share/cups/ppdc/liblouis3.defs
-share/cups/ppdc/liblouis4.defs
-share/cups/ppdc/media-braille.defs
+%%BRAILLE%%share/cups/ppdc/fr-braille.po
+%%BRAILLE%%share/cups/ppdc/imagemagick.defs
+%%BRAILLE%%share/cups/ppdc/index.defs
+%%BRAILLE%%share/cups/ppdc/liblouis.defs
+%%BRAILLE%%share/cups/ppdc/liblouis1.defs
+%%BRAILLE%%share/cups/ppdc/liblouis2.defs
+%%BRAILLE%%share/cups/ppdc/liblouis3.defs
+%%BRAILLE%%share/cups/ppdc/liblouis4.defs
+%%BRAILLE%%share/cups/ppdc/media-braille.defs
share/cups/ppdc/pcl.h
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
@@ -116,7 +117,7 @@ share/cups/ppdc/pcl.h
share/ppd/cupsfilters/Fuji_Xerox-DocuPrint_CM305_df-PDF.ppd
share/ppd/cupsfilters/Generic-PDF_Printer-PDF.ppd
share/ppd/cupsfilters/HP-Color_LaserJet_CM3530_MFP-PDF.ppd
-share/ppd/cupsfilters/HP-PhotoSmart_Pro_B8300-hpijs-pdftoijs.ppd
+%%IJS%%share/ppd/cupsfilters/HP-PhotoSmart_Pro_B8300-hpijs-pdftoijs.ppd
share/ppd/cupsfilters/Ricoh-PDF_Printer-PDF.ppd
share/ppd/cupsfilters/pxlcolor.ppd
share/ppd/cupsfilters/pxlmono.ppd