aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-26 21:37:44 +0800
committerkrion <krion@FreeBSD.org>2004-01-26 21:37:44 +0800
commit83169e4e96168aaeaf619e771030f6e8a12be72b (patch)
tree99d3ba4b61f1192035a8b19a74eefa4c861b9ce5 /print
parentf95da47d0745ed4c32bdc5bb1290ab6c07dc7003 (diff)
downloadfreebsd-ports-gnome-83169e4e96168aaeaf619e771030f6e8a12be72b.tar.gz
freebsd-ports-gnome-83169e4e96168aaeaf619e771030f6e8a12be72b.tar.zst
freebsd-ports-gnome-83169e4e96168aaeaf619e771030f6e8a12be72b.zip
Add latex-bibtopic 1.0.20020822,
bibtopic is a LaTeX package for including several bibliographies in a document. These bibliographies might be considered to cover different topics (hence the name) or bibliographic material (e.g., primary and secondary literature) and the like. PR: ports/61922 Submitted by: hrs@FreeBSD.org
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-bibtopic/Makefile56
-rw-r--r--print/latex-bibtopic/distinfo3
-rw-r--r--print/latex-bibtopic/pkg-descr4
-rw-r--r--print/latex-bibtopic/pkg-plist9
5 files changed, 73 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 64ae512c3441..96c4cb8c9e29 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -93,6 +93,7 @@
SUBDIR += kover
SUBDIR += latex
SUBDIR += latex-beamer
+ SUBDIR += latex-bibtopic
SUBDIR += latex-caption
SUBDIR += latex-feynmf
SUBDIR += latex-keystroke
diff --git a/print/latex-bibtopic/Makefile b/print/latex-bibtopic/Makefile
new file mode 100644
index 000000000000..d5fbec61aa2a
--- /dev/null
+++ b/print/latex-bibtopic/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: latex-bibtopic
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-bibtopic
+PORTVERSION= 1.0.20020822
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/bibtopic
+DISTFILES= ${DOC_FILES} bibtopic.dtx bibtopic.ins
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package allows several bibliographies in a document
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/latex
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+
+DOC_FILES= README
+
+CLASS_FILES= bibtopic.sty
+CLASS_FILES+= bibtopic.ins bibtopic.dtx
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${TEX_BIN} bibtopic.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-bibtopic/distinfo b/print/latex-bibtopic/distinfo
new file mode 100644
index 000000000000..65c29099353a
--- /dev/null
+++ b/print/latex-bibtopic/distinfo
@@ -0,0 +1,3 @@
+MD5 (latex-bibtopic/README) = 8f0046ddf0246c12e13a3de06ba51218
+MD5 (latex-bibtopic/bibtopic.dtx) = 17d310abb5753915008c7d219a4a0876
+MD5 (latex-bibtopic/bibtopic.ins) = 656d56275f34bba79f3f8c2d469c1754
diff --git a/print/latex-bibtopic/pkg-descr b/print/latex-bibtopic/pkg-descr
new file mode 100644
index 000000000000..06e934056e58
--- /dev/null
+++ b/print/latex-bibtopic/pkg-descr
@@ -0,0 +1,4 @@
+bibtopic is a LaTeX package for including several bibliographies in
+a document. These bibliographies might be considered to cover different
+topics (hence the name) or bibliographic material (e.g., primary and
+secondary literature) and the like.
diff --git a/print/latex-bibtopic/pkg-plist b/print/latex-bibtopic/pkg-plist
new file mode 100644
index 000000000000..634686b56e32
--- /dev/null
+++ b/print/latex-bibtopic/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/bibtopic.dtx
+%%CLASSDIR%%/bibtopic.ins
+%%CLASSDIR%%/bibtopic.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%