aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-02-20 00:43:11 +0800
committerpawel <pawel@FreeBSD.org>2013-02-20 00:43:11 +0800
commit8b086817bd714067139e895cf15dda0879bfec5b (patch)
tree3f24be262776e47e43c1b31552e776710766210a /print
parent8795bbba3e0bc773b3f54541af42a50871d34a8c (diff)
downloadfreebsd-ports-gnome-8b086817bd714067139e895cf15dda0879bfec5b.tar.gz
freebsd-ports-gnome-8b086817bd714067139e895cf15dda0879bfec5b.tar.zst
freebsd-ports-gnome-8b086817bd714067139e895cf15dda0879bfec5b.zip
- Update to version 0.4
- Add optional support for DjVu and PostScript While here: - Respect CFLAGS, CXXFLAGS - Fix WWW line, convert tab -> space PR: ports/176244 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com> (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/qpdfview/Makefile47
-rw-r--r--print/qpdfview/distinfo4
-rw-r--r--print/qpdfview/pkg-descr2
-rw-r--r--print/qpdfview/pkg-plist10
4 files changed, 52 insertions, 11 deletions
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 8f9436027883..87b29cf5d8e1 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= qpdfview
-PORTVERSION= 0.3.7
+PORTVERSION= 0.4
CATEGORIES= print
-MASTER_SITES= https://launchpadlibrarian.net/125207295/
-DISTNAME= ${PORTNAME}-${PORTVERSION}beta1
+MASTER_SITES= https://launchpadlibrarian.net/131409309/
MAINTAINER= g.veniamin@googlemail.com
COMMENT= Tabbed PDF viewer using the poppler library
@@ -15,15 +14,49 @@ LICENSE= GPLv2
LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
cups:${PORTSDIR}/print/cups-client
-USE_QT4= corelib dbus gui moc_build qmake_build rcc sql svg xml
+USE_QT4= corelib dbus gui moc_build qmake_build rcc_build sql sql-sqlite3_run \
+ svg xml
+QMAKEFLAGS+= QMAKE_CFLAGS_RELEASE="" QMAKE_CXXFLAGS_RELEASE=""
+
+DATADIR= ${PREFIX}/share/${PORTNAME}
MAN1= ${PORTNAME}.1
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DJVU PDF PS
+DJVU_DESC= DjVu support
+PS_DESC= PostScript support
+OPTIONS_DEFAULT= PDF
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDJVU}
+PLIST_SUB+= DJVU=""
+LIB_DEPENDS+= djvulibre:${PORTSDIR}/graphics/djvulibre
+.else
+QMAKEFLAGS+= "CONFIG+=without_djvu"
+PLIST_SUB+= DJVU="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPDF}
+PLIST_SUB+= PDF=""
+.else
+QMAKEFLAGS+= "CONFIG+=without_pdf"
+PLIST_SUB+= PDF="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPS}
+PLIST_SUB+= PS=""
+LIB_DEPENDS+= spectre:${PORTSDIR}/print/libspectre
+.else
+QMAKEFLAGS+= "CONFIG+=without_ps"
+PLIST_SUB+= PS="@comment "
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's#/usr#${PREFIX}#g;s#${PREFIX}/share/man#${PREFIX}/man#g' \
${WRKSRC}/${PORTNAME}.pri
do-configure:
- cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS}
-.include <bsd.port.post.mk>
+ cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS} ${PORTNAME}.pro
+
+.include <bsd.port.mk>
diff --git a/print/qpdfview/distinfo b/print/qpdfview/distinfo
index 9ec8dfe8b4f6..2b488478e70f 100644
--- a/print/qpdfview/distinfo
+++ b/print/qpdfview/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qpdfview-0.3.7beta1.tar.gz) = 4541ea36c985bb1442329f7726fc430a93db2e364b6c303d975fc8b2d974cdce
-SIZE (qpdfview-0.3.7beta1.tar.gz) = 359083
+SHA256 (qpdfview-0.4.tar.gz) = 6191e6ae15f228bce9ac0c58dd5032122fa2986d50f7585859cd64a7fd2b5499
+SIZE (qpdfview-0.4.tar.gz) = 396479
diff --git a/print/qpdfview/pkg-descr b/print/qpdfview/pkg-descr
index 25e6b1f2aa5b..fb3d28efaa6b 100644
--- a/print/qpdfview/pkg-descr
+++ b/print/qpdfview/pkg-descr
@@ -1,3 +1,3 @@
qpdfview is a tabbed PDF viewer using the poppler library.
-WWW: https://launchpad.net/qpdfview
+WWW: https://launchpad.net/qpdfview
diff --git a/print/qpdfview/pkg-plist b/print/qpdfview/pkg-plist
index 9d5b006ad940..f5308c538369 100644
--- a/print/qpdfview/pkg-plist
+++ b/print/qpdfview/pkg-plist
@@ -1,4 +1,7 @@
bin/qpdfview
+%%DJVU%%lib/qpdfview/libqpdfview_djvu.so
+%%PDF%%lib/qpdfview/libqpdfview_pdf.so
+%%PS%%lib/qpdfview/libqpdfview_ps.so
share/applications/qpdfview.desktop
%%DATADIR%%/help.html
%%DATADIR%%/qpdfview.svg
@@ -11,11 +14,15 @@ share/applications/qpdfview.desktop
%%DATADIR%%/qpdfview_el.qm
%%DATADIR%%/qpdfview_en_GB.qm
%%DATADIR%%/qpdfview_es.qm
+%%DATADIR%%/qpdfview_eu.qm
%%DATADIR%%/qpdfview_fi.qm
%%DATADIR%%/qpdfview_fr.qm
%%DATADIR%%/qpdfview_he.qm
%%DATADIR%%/qpdfview_hr.qm
+%%DATADIR%%/qpdfview_id.qm
%%DATADIR%%/qpdfview_it.qm
+%%DATADIR%%/qpdfview_ky.qm
+%%DATADIR%%/qpdfview_ms.qm
%%DATADIR%%/qpdfview_my.qm
%%DATADIR%%/qpdfview_pl.qm
%%DATADIR%%/qpdfview_pt_BR.qm
@@ -26,5 +33,6 @@ share/applications/qpdfview.desktop
%%DATADIR%%/qpdfview_ug.qm
%%DATADIR%%/qpdfview_uk.qm
%%DATADIR%%/qpdfview_zh_CN.qm
-@dirrmtry share/applications
@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@dirrmtry lib/qpdfview