aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-05-04 04:54:49 +0800
committerrakuco <rakuco@FreeBSD.org>2017-05-04 04:54:49 +0800
commita5efd86061fa09ae54faf5c7f9b335930d7048e7 (patch)
tree4bfc1d8a482ec6953c0ac90b787f1059439d43ad /print
parentab6b73d58d5f5b0443be51867ce54e6b2adf2653 (diff)
downloadfreebsd-ports-gnome-a5efd86061fa09ae54faf5c7f9b335930d7048e7.tar.gz
freebsd-ports-gnome-a5efd86061fa09ae54faf5c7f9b335930d7048e7.tar.zst
freebsd-ports-gnome-a5efd86061fa09ae54faf5c7f9b335930d7048e7.zip
Fix shebangs.
Diffstat (limited to 'print')
-rw-r--r--print/lyx/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index f98914cbb858..6b96f64d3972 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lyx
PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -22,7 +22,7 @@ MAJOR_VERSION= 2.2
MINOR_VERSION= 2
USES= desktop-file-utils execinfo gmake iconv pkgconfig perl5 \
- python:2 tar:xz
+ python:2 shebangfix tar:xz
USE_QT5= core concurrent gui svg widgets buildtools_build qmake_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-boost \
@@ -31,6 +31,9 @@ CONFIGURE_ARGS= --without-included-boost \
--with-qt-dir=${LOCALBASE}/lib/qt5 \
${ICONV_CONFIGURE_ARG} \
--with-extra-prefix=${LOCALBASE}
+SHEBANG_FILES= lib/configure.py \
+ lib/lyx2lyx/lyx2lyx \
+ lib/scripts/listerrors
CPPFLAGS+= ${EXECINFO_CPPFLAGS}
LDFLAGS+= ${EXECINFO_LDFLAGS}