aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-06-03 02:54:51 +0800
committerpawel <pawel@FreeBSD.org>2013-06-03 02:54:51 +0800
commitaddbe4de602baf969cc07d9bf9296f2d3d842567 (patch)
treec02821b6c7e06879dffea25a44bd221b9796c282 /print
parentde9af8761237dd0eb39787185b8e02da0b1d1004 (diff)
downloadfreebsd-ports-gnome-addbe4de602baf969cc07d9bf9296f2d3d842567.tar.gz
freebsd-ports-gnome-addbe4de602baf969cc07d9bf9296f2d3d842567.tar.zst
freebsd-ports-gnome-addbe4de602baf969cc07d9bf9296f2d3d842567.zip
* update to 0.9.13
* new MASTER_SITES (Makefile) * new project's home (pkg_descr) * pet portlint * removing patches accepted upstream PR: ports/179177 Submitted by: Nikola Lecic <nikola.lecic@anthesphoria.net> (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/libotf/Makefile14
-rw-r--r--print/libotf/distinfo4
-rw-r--r--print/libotf/files/patch-example_otfdump.c25
-rw-r--r--print/libotf/files/patch-src_otfopen.c45
-rw-r--r--print/libotf/pkg-descr2
5 files changed, 8 insertions, 82 deletions
diff --git a/print/libotf/Makefile b/print/libotf/Makefile
index 02c048da6bca..20f5a9869bff 100644
--- a/print/libotf/Makefile
+++ b/print/libotf/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: libotf
-# Date created: 18 May 2004
-# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
-#
+# Created by: Kimura Fuyuki <fuyuki@hadaly.org>
# $FreeBSD$
-#
PORTNAME= libotf
-PORTVERSION= 0.9.12
+PORTVERSION= 0.9.13
CATEGORIES= print devel
-MASTER_SITES= http://www.m17n.org/libotf/ \
- http://anthesphoria.net/FreeBSD/ports/distfiles/
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}:m17n
+MASTER_SITE_SUBDIR= m17n
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= Library for handling OpenType fonts
@@ -17,7 +13,7 @@ COMMENT= Library for handling OpenType fonts
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_XORG= x11 xt xaw xmu
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/libotf/distinfo b/print/libotf/distinfo
index ca7981fd4fa9..29a695fdb461 100644
--- a/print/libotf/distinfo
+++ b/print/libotf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libotf-0.9.12.tar.gz) = a4a04cccf84955242202a4a7e50314259030c1f1573675085ba1c5a95b529297
-SIZE (libotf-0.9.12.tar.gz) = 363974
+SHA256 (libotf-0.9.13.tar.gz) = 7bc466ba50425f95b52de12b4ad35320acefcef13ce67bf33edc14abdcfe6908
+SIZE (libotf-0.9.13.tar.gz) = 388832
diff --git a/print/libotf/files/patch-example_otfdump.c b/print/libotf/files/patch-example_otfdump.c
deleted file mode 100644
index 038ab02edfc2..000000000000
--- a/print/libotf/files/patch-example_otfdump.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- example/otfdump.c 19 Mar 2010 12:27:02 -0000 1.27
-+++ example/otfdump.c 11 Feb 2011 02:52:37 -0000 1.28
-@@ -32,12 +32,8 @@
-
- #include <otf.h>
-
--char *indent_spaces[] =
-- { "", " ", " ", " ", " ", " ", " ",
-- " ", " ", " " };
--
- /* Indented print. */
--#define IPRINT printf("\n%s", indent_spaces[indent]), printf
-+#define IPRINT printf("\n%*s", indent * 2, ""), printf
-
- static void
- dump_tag (OTF_Tag tag)
-@@ -457,6 +453,8 @@
- static void
- dump_anchor (int indent, OTF_Anchor *anchor)
- {
-+ if (anchor->offset == 0)
-+ return;
- IPRINT ("(Anchor (offset #x%04X) (AnchorFormat %d)",
- anchor->offset, anchor->AnchorFormat);
- indent++;
diff --git a/print/libotf/files/patch-src_otfopen.c b/print/libotf/files/patch-src_otfopen.c
deleted file mode 100644
index 319b92a958b9..000000000000
--- a/print/libotf/files/patch-src_otfopen.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/otfopen.c 22 Sep 2010 03:46:17 -0000 1.62
-+++ src/otfopen.c 11 Feb 2011 02:55:05 -0000 1.63
-@@ -2336,8 +2336,9 @@
- }
- for (i = 0; i < array->Count; i++)
- for (j = 0; j < ClassCount; j++)
-- if (read_anchor (otf, stream, offset + array->offset,
-- &array->AnchorRecord[i].Anchor[j]) < 0)
-+ if (array->AnchorRecord[i].Anchor[j].offset > 0
-+ && read_anchor (otf, stream, offset + array->offset,
-+ &array->AnchorRecord[i].Anchor[j]) < 0)
- return -1;
- RESTORE_STREAM (stream, state);
- return 0;
-@@ -2437,7 +2438,7 @@
- unsigned ClassCount, OTF_LigatureAttach *attach)
- {
- char *errfmt = "LigatureAttach%s";
-- int errret = 1;
-+ int errret = -1;
- int i, j;
-
- SEEK_STREAM (stream, offset + attach->offset);
-@@ -2483,8 +2484,10 @@
- for (i = 0; i < array->LigatureCount; i++)
- READ_OFFSET (stream, array->LigatureAttach[i].offset);
- for (i = 0; i < array->LigatureCount; i++)
-- read_ligature_attach (otf, stream, offset + array->offset,
-- class_count, array->LigatureAttach + i);
-+ if (array->LigatureAttach[i].offset > 0
-+ && read_ligature_attach (otf, stream, offset + array->offset,
-+ class_count, array->LigatureAttach + i) < 0)
-+ return -1;
- RESTORE_STREAM (stream, state);
- return 0;
- }
-@@ -2625,7 +2628,7 @@
- read_coverage (otf, stream, offset, &subtable->Coverage);
- read_coverage (otf, stream, offset,
- &subtable->u.mark_mark1.Mark2Coverage);
-- READ_UINT16 (stream, subtable->u.mark_base1.ClassCount);
-+ READ_UINT16 (stream, subtable->u.mark_mark1.ClassCount);
- read_mark_array (otf, stream, offset,
- &subtable->u.mark_mark1.Mark1Array);
- read_anchor_array (otf, stream, offset,
diff --git a/print/libotf/pkg-descr b/print/libotf/pkg-descr
index 616abb234929..77562b06933e 100644
--- a/print/libotf/pkg-descr
+++ b/print/libotf/pkg-descr
@@ -9,4 +9,4 @@ The library "libotf" provides the following facilites:
The combination of libotf and the FreeType library (Ver. 2) realizes
CTL (complex text layout) by OpenType fonts.
-WWW: http://www.m17n.org/libotf/
+WWW: http://www.nongnu.org/m17n/