aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2009-01-19 21:52:42 +0800
committerrafan <rafan@FreeBSD.org>2009-01-19 21:52:42 +0800
commiteb70492fd1347b052333bb5fc6b38f177581cd78 (patch)
tree5359c74606f26621df32ce3e9ef658b1e4b57fe0 /print
parentd2e58aa0ad7866cf22344e9f550f3177805a7a6d (diff)
downloadfreebsd-ports-gnome-eb70492fd1347b052333bb5fc6b38f177581cd78.tar.gz
freebsd-ports-gnome-eb70492fd1347b052333bb5fc6b38f177581cd78.tar.zst
freebsd-ports-gnome-eb70492fd1347b052333bb5fc6b38f177581cd78.zip
Add pkipplib which is a prerequisite of pykota.
pkipplib is a Python library which can prepare IPP requests with the help of a somewhat high level API. These requests can then be sent to an IPP printer or print server (e.g. CUPS). This library can also parse IPP answers received, and create high level Python objects from them. WWW: http://www.pykota.com/software/pkipplib/
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/pkipplib/Makefile19
-rw-r--r--print/pkipplib/distinfo3
-rw-r--r--print/pkipplib/pkg-descr6
-rw-r--r--print/pkipplib/pkg-plist11
5 files changed, 40 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index bd379ccd21cf..4ed65f753d69 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -269,6 +269,7 @@
SUBDIR += pkfonts360
SUBDIR += pkfonts400
SUBDIR += pkfonts600
+ SUBDIR += pkipplib
SUBDIR += pkpgcounter
SUBDIR += pmw
SUBDIR += pnm2ppa
diff --git a/print/pkipplib/Makefile b/print/pkipplib/Makefile
new file mode 100644
index 000000000000..bd70cf509aa9
--- /dev/null
+++ b/print/pkipplib/Makefile
@@ -0,0 +1,19 @@
+# Ports collection Makefile for: pkipplib
+# Date created: Jan 19 2009
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkipplib
+PORTVERSION= 0.07
+CATEGORIES= print python
+MASTER_SITES= http://www.pykota.com/software/pkipplib/download/tarballs/
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Create and parse IPP requests
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/print/pkipplib/distinfo b/print/pkipplib/distinfo
new file mode 100644
index 000000000000..70a8069df787
--- /dev/null
+++ b/print/pkipplib/distinfo
@@ -0,0 +1,3 @@
+MD5 (pkipplib-0.07.tar.gz) = 6e59a148f6ebf7c4344a7a2f1c2aea3c
+SHA256 (pkipplib-0.07.tar.gz) = 2a2c8fd9fda3d31c30cd48f93d22fe419ec6dc5de53c93183e66fbe579c1908b
+SIZE (pkipplib-0.07.tar.gz) = 18704
diff --git a/print/pkipplib/pkg-descr b/print/pkipplib/pkg-descr
new file mode 100644
index 000000000000..8f5ba75dd081
--- /dev/null
+++ b/print/pkipplib/pkg-descr
@@ -0,0 +1,6 @@
+pkipplib is a Python library which can prepare IPP requests with the
+help of a somewhat high level API. These requests can then be sent to
+an IPP printer or print server (e.g. CUPS). This library can also parse
+IPP answers received, and create high level Python objects from them.
+
+WWW: http://www.pykota.com/software/pkipplib/
diff --git a/print/pkipplib/pkg-plist b/print/pkipplib/pkg-plist
new file mode 100644
index 000000000000..d3dab4090094
--- /dev/null
+++ b/print/pkipplib/pkg-plist
@@ -0,0 +1,11 @@
+bin/pksubscribe
+%%PYTHON_SITELIBDIR%%/pkipplib/__init__.py
+%%PYTHON_SITELIBDIR%%/pkipplib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pkipplib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pkipplib/pkipplib.py
+%%PYTHON_SITELIBDIR%%/pkipplib/pkipplib.pyc
+%%PYTHON_SITELIBDIR%%/pkipplib/pkipplib.pyo
+%%PYTHON_SITELIBDIR%%/pkipplib/version.py
+%%PYTHON_SITELIBDIR%%/pkipplib/version.pyc
+%%PYTHON_SITELIBDIR%%/pkipplib/version.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/pkipplib