aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-11-29 22:55:33 +0800
committerdinoex <dinoex@FreeBSD.org>2009-11-29 22:55:33 +0800
commitf5dbd6633680fb12edaa3ae1a5090b48a48cd0c2 (patch)
tree65d0197212e0ad8bb65f59119841f0829141d75b /print
parentf791649b94f0cd299e16e04cee2ac19889b6c792 (diff)
downloadfreebsd-ports-gnome-f5dbd6633680fb12edaa3ae1a5090b48a48cd0c2.tar.gz
freebsd-ports-gnome-f5dbd6633680fb12edaa3ae1a5090b48a48cd0c2.tar.zst
freebsd-ports-gnome-f5dbd6633680fb12edaa3ae1a5090b48a48cd0c2.zip
- Fix build of option WITH_PAM
- cleanup REINPLACE PR: 140996
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 26e8542a8837..a8fe717fb32d 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -227,33 +227,29 @@ pre-configure::
@${ECHO_MSG} Configuring CUPS with options:
@${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
-.if defined(WITH_PAM)
-post-configure:
- ${GREP} -v pam_securityserver ${WRKSRC}/conf/pam.darwin > ${WRKSRC}/conf/pam.std
-.endif
-
post-patch:
.if defined(WITH_XDG_OPEN)
- @${REINPLACE_CMD} -e 's|htmlview|xdg-open|' ${WRKSRC}/desktop/cups.desktop
+ @${REINPLACE_CMD} -e 's|htmlview|xdg-open|' ${WRKSRC}/desktop/cups.desktop.in
.endif
@${REINPLACE_CMD} -e '/SILENT/d' ${WRKSRC}/Makedefs.in
@${REINPLACE_CMD} -e 's|/etc/cups|${LOCALBASE}/etc/cups|g' ${WRKSRC}/man/*.man*
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/scheduler/cups-driverd.cxx
- @${REINPLACE_CMD} -e 's|CXX="$$CC"||g ; s|-lpthreads.*;|${PTHREAD_LIBS};|g' \
+ @${REINPLACE_CMD} -e 's|-lpthreads.*;|${PTHREAD_LIBS};|g' \
-e 's|/private/etc/pam.d|${LOCALBASE}/etc/pam.d|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(CUPS_CLIENT)
@${REINPLACE_CMD} \
- -e 's|backend berkeley cgi-bin filter locale man monitor ||' \
- -e 's|notifier scheduler systemv test ||' \
+ -e 's|cups filter |cups |' \
+ -e 's|backend berkeley cgi-bin driver locale man monitor||' \
+ -e 's|notifier ppdc scheduler systemv test ||' \
-e 's|$$.PHPDIR. ||' \
-e 's|conf data doc $$.FONTS.ppd templates||' \
-e 's|/usr/share|${PREFIX}/share|g' \
${WRKSRC}/Makefile
.elif defined(CUPS_IMAGE)
@${REINPLACE_CMD} \
- -e 's|cups backend berkeley cgi-bin filter locale man monitor |filter |' \
- -e 's|notifier scheduler systemv test ||' \
+ -e 's|cups filter |filter |' \
+ -e 's|backend berkeley cgi-bin driver locale man monitor||' \
+ -e 's|notifier ppdc scheduler systemv test ||' \
-e 's|$$.PHPDIR. ||' \
-e 's|conf data doc $$.FONTS.ppd templates||' \
-e 's|/usr/share|${PREFIX}/share|g' \