aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-08-22 19:45:41 +0800
committertg <tg@FreeBSD.org>2000-08-22 19:45:41 +0800
commit16ecf88f3035902920a9b59d76fc5192054a74d2 (patch)
tree34bd09f7d2296b170aca468b02c583c958826a8f /print
parent4e4b26422a0bb14d2f3b3f696b5c33d4a5b5f8dc (diff)
downloadfreebsd-ports-gnome-16ecf88f3035902920a9b59d76fc5192054a74d2.tar.gz
freebsd-ports-gnome-16ecf88f3035902920a9b59d76fc5192054a74d2.tar.zst
freebsd-ports-gnome-16ecf88f3035902920a9b59d76fc5192054a74d2.zip
New port py-reportlab, a library for creating PDF documents using Python.
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-reportlab/Makefile48
-rw-r--r--print/py-reportlab/distinfo1
-rw-r--r--print/py-reportlab/pkg-comment1
-rw-r--r--print/py-reportlab/pkg-descr23
-rw-r--r--print/py-reportlab/pkg-plist130
6 files changed, 204 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 9e4cccc0d859..3f09553259d3 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -82,6 +82,7 @@
SUBDIR += pstotext
SUBDIR += psutils-a4
SUBDIR += psutils-letter
+ SUBDIR += py-reportlab
SUBDIR += rlpr
SUBDIR += rtf2latex
SUBDIR += t1utils
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
new file mode 100644
index 000000000000..9cbd07d8706a
--- /dev/null
+++ b/print/py-reportlab/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: reportlab
+# Date created: 17 August 2000
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reportlab
+PORTVERSION= 1.0
+CATEGORIES= print python
+MASTER_SITES= ftp://ftp.reportlab.com/
+PKGNAMEPREFIX= py-
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_BUILD= yes
+PLIST_SUB= PYVERSION=${PYVERSION}
+
+PYVERSION= python1.5
+PYTHONSCRIPTDIR= ${PREFIX}/lib/${PYVERSION}
+REPORTLABDIR= ${PYTHONSCRIPTDIR}/site-packages/reportlab
+DOCDIR= ${PREFIX}/share/doc/reportlab
+EXAMPLEDIR= ${PREFIX}/share/examples/reportlab
+
+do-install:
+ @${MKDIR} ${REPORTLABDIR}
+.for dir in . lib pdfbase pdfgen platypus
+ @${MKDIR} ${REPORTLABDIR}/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/*.py ${REPORTLABDIR}/${dir}
+.endfor
+ ${ECHO} 'reportlab' > ${PYTHONSCRIPTDIR}/reportlab.pth
+ @${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${REPORTLABDIR}
+ @${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${REPORTLABDIR}
+
+ @${MKDIR} ${EXAMPLEDIR}
+ cd ${WRKSRC}/demos; tar cpf - * | (cd ${EXAMPLEDIR}; tar xpf -)
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/py-reportlab/distinfo b/print/py-reportlab/distinfo
new file mode 100644
index 000000000000..d6ec9bf2b10e
--- /dev/null
+++ b/print/py-reportlab/distinfo
@@ -0,0 +1 @@
+MD5 (reportlab.tgz) = 6c8da48a5e5483842419da9e195a6748
diff --git a/print/py-reportlab/pkg-comment b/print/py-reportlab/pkg-comment
new file mode 100644
index 000000000000..e6ceee97a938
--- /dev/null
+++ b/print/py-reportlab/pkg-comment
@@ -0,0 +1 @@
+Library to create PDF documents using the Python language
diff --git a/print/py-reportlab/pkg-descr b/print/py-reportlab/pkg-descr
new file mode 100644
index 000000000000..31315ffa536a
--- /dev/null
+++ b/print/py-reportlab/pkg-descr
@@ -0,0 +1,23 @@
+ReportLab is a software library that lets you directly create
+documents in Adobe's Portabe Document Format (PDF) using the Python
+programming language.
+
+The ReportLab library directly creates PDF based on your graphics
+commands. There are no intervening steps. Your applications can
+generate reports extremely fast - sometimes orders of magnitude
+faster than traditional report-writing tools.
+
+The ReportLab library is expected to be useful in at least the
+following contexts:
+
+- Dynamic PDF generation on the web
+- High-volume corporate reporting and database publishing
+- An embeddable print engine for other applications, including
+ a 'report language' so that users can customize their own reports.
+- A 'build system' for complex documents with charts, tables
+ and text such as management accounts, statistical reports and
+ scientific papers
+- Going from XML to PDF in one step!
+
+
+WWW: http://www.reportlab.com/
diff --git a/print/py-reportlab/pkg-plist b/print/py-reportlab/pkg-plist
new file mode 100644
index 000000000000..804d14477cfd
--- /dev/null
+++ b/print/py-reportlab/pkg-plist
@@ -0,0 +1,130 @@
+lib/%%PYVERSION%%/site-packages/reportlab/__init__.py
+lib/%%PYVERSION%%/site-packages/reportlab/__init__.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/__init__.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/__init__.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/__init__.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/__init__.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/colors.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/colors.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/colors.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/corp.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/corp.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/corp.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/enums.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/enums.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/enums.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/fonts.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/fonts.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/fonts.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/pagesizes.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/pagesizes.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/pagesizes.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/sequencer.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/sequencer.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/sequencer.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/styles.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/styles.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/styles.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/units.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/units.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/units.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/lib/xmllib.py
+lib/%%PYVERSION%%/site-packages/reportlab/lib/xmllib.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/lib/xmllib.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/__init__.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/__init__.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/__init__.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfdoc.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfdoc.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfdoc.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfmetrics.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfmetrics.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfmetrics.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfutils.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfutils.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfbase/pdfutils.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/__init__.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/__init__.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/__init__.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/canvas.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/canvas.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/canvas.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/pathobject.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/pathobject.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/pathobject.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/pdfgeom.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/pdfgeom.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/pdfgeom.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/textobject.py
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/textobject.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/pdfgen/textobject.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/__init__.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/__init__.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/__init__.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/doctemplate.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/doctemplate.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/doctemplate.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/flowables.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/flowables.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/flowables.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/frames.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/frames.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/frames.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/paragraph.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/paragraph.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/paragraph.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/paraparser.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/paraparser.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/paraparser.pyo
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/tables.py
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/tables.pyc
+lib/%%PYVERSION%%/site-packages/reportlab/platypus/tables.pyo
+share/doc/reportlab/reference.pdf
+share/doc/reportlab/userguide.pdf
+share/examples/reportlab/colors/colortest.py
+share/examples/reportlab/gadflypaper/00readme.txt
+share/examples/reportlab/gadflypaper/gfe.py
+share/examples/reportlab/odyssey/00readme.txt
+share/examples/reportlab/odyssey/dodyssey.py
+share/examples/reportlab/odyssey/fodyssey.py
+share/examples/reportlab/odyssey/odyssey.py
+share/examples/reportlab/odyssey/odyssey.txt
+share/examples/reportlab/py2pdf/00readme.txt
+share/examples/reportlab/py2pdf/PyFontify.py
+share/examples/reportlab/py2pdf/demo-config.txt
+share/examples/reportlab/py2pdf/demo.py
+share/examples/reportlab/py2pdf/idle_print.py
+share/examples/reportlab/py2pdf/py2pdf.py
+share/examples/reportlab/py2pdf/vertpython.jpg
+share/examples/reportlab/pythonpoint/00readme.txt
+share/examples/reportlab/pythonpoint/customshapes.py
+share/examples/reportlab/pythonpoint/leftlogo.a85
+share/examples/reportlab/pythonpoint/leftlogo.gif
+share/examples/reportlab/pythonpoint/lj8100.jpg
+share/examples/reportlab/pythonpoint/monterey.xml
+share/examples/reportlab/pythonpoint/outline.gif
+share/examples/reportlab/pythonpoint/python.gif
+share/examples/reportlab/pythonpoint/pythonpoint.py
+share/examples/reportlab/pythonpoint/pythonpoint.xml
+share/examples/reportlab/pythonpoint/spectrum.png
+share/examples/reportlab/pythonpoint/stdparser.py
+share/examples/reportlab/pythonpoint/styles_horrible.py
+share/examples/reportlab/pythonpoint/styles_modern.py
+share/examples/reportlab/pythonpoint/vertpython.gif
+share/examples/reportlab/stdfonts/00readme.txt
+share/examples/reportlab/stdfonts/stdfonts.py
+share/examples/reportlab/tests/testdemos.py
+@dirrm share/examples/reportlab/tests
+@dirrm share/examples/reportlab/stdfonts
+@dirrm share/examples/reportlab/pythonpoint
+@dirrm share/examples/reportlab/py2pdf
+@dirrm share/examples/reportlab/odyssey
+@dirrm share/examples/reportlab/gadflypaper
+@dirrm share/examples/reportlab/colors
+@dirrm share/examples/reportlab
+@dirrm share/doc/reportlab
+@dirrm lib/%%PYVERSION%%/site-packages/reportlab/platypus
+@dirrm lib/%%PYVERSION%%/site-packages/reportlab/pdfgen
+@dirrm lib/%%PYVERSION%%/site-packages/reportlab/pdfbase
+@dirrm lib/%%PYVERSION%%/site-packages/reportlab/lib
+@dirrm lib/%%PYVERSION%%/site-packages/reportlab