aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-17 16:55:50 +0800
committerrm <rm@FreeBSD.org>2012-10-17 16:55:50 +0800
commit1fda59e088d26900d947e1728464e30e991609a9 (patch)
tree04d85610bbf3d64164e5b2c0efdf9eff49904c64 /print
parentfd334fa74c9ed103c6d5406f548b72b9c93c5ed5 (diff)
downloadfreebsd-ports-gnome-1fda59e088d26900d947e1728464e30e991609a9.tar.gz
freebsd-ports-gnome-1fda59e088d26900d947e1728464e30e991609a9.tar.zst
freebsd-ports-gnome-1fda59e088d26900d947e1728464e30e991609a9.zip
PollyReports.py provides a set of classes for database report writing.
It assumes that you are using Reportlab to do PDF generation, but can work with any "canvas-like" object as desired. WWW: http://newcenturycomputers.net/projects/pollyreports.html PR: 172537 Submitted by: Jose Jachuf <jjachuf at gmail dot com> Feature safe: yes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-pollyreports/Makefile32
-rw-r--r--print/py-pollyreports/distinfo2
-rw-r--r--print/py-pollyreports/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index b3b462419367..5a0723e4b650 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -251,6 +251,7 @@
SUBDIR += py-cups
SUBDIR += py-fonttools
SUBDIR += py-pdf
+ SUBDIR += py-pollyreports
SUBDIR += py-pyscript
SUBDIR += py-relatorio
SUBDIR += py-reportlab
diff --git a/print/py-pollyreports/Makefile b/print/py-pollyreports/Makefile
new file mode 100644
index 000000000000..da37fad2e0d5
--- /dev/null
+++ b/print/py-pollyreports/Makefile
@@ -0,0 +1,32 @@
+# Created by: Jose Jachuf <jjachuf@gmail.com>
+# $FreeBSD$
+
+PORTNAME= PollyReports
+PORTVERSION= 1.6.6
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jjachuf@gmail.com
+COMMENT= Band-oriented PDF report generation from database query
+
+LICENSE= BSD
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS=yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/PollyReports.py \
+ %%PYTHON_SITELIBDIR%%/PollyReports.pyc \
+ %%PYTHON_SITELIBDIR%%/PollyReports.pyo
+
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
+OPTIONS_DEFINE= REPORTLAB
+REPORTLAB_DESC= Install Reportlab2
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MREPORTLAB}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab2>=2.1:${PORTSDIR}/print/py-reportlab2
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/py-pollyreports/distinfo b/print/py-pollyreports/distinfo
new file mode 100644
index 000000000000..8060a60bc32d
--- /dev/null
+++ b/print/py-pollyreports/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PollyReports-1.6.6.tar.gz) = 1a03b1b1506393bc76488dfe3c5caf87588ccf1ec6f8f629af40ce6f3549bf14
+SIZE (PollyReports-1.6.6.tar.gz) = 19874
diff --git a/print/py-pollyreports/pkg-descr b/print/py-pollyreports/pkg-descr
new file mode 100644
index 000000000000..b53d04f4936c
--- /dev/null
+++ b/print/py-pollyreports/pkg-descr
@@ -0,0 +1,5 @@
+PollyReports.py provides a set of classes for database report writing.
+It assumes that you are using Reportlab to do PDF generation, but can
+work with any "canvas-like" object as desired.
+
+WWW: http://newcenturycomputers.net/projects/pollyreports.html