aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-26 04:12:31 +0800
committerkrion <krion@FreeBSD.org>2004-01-26 04:12:31 +0800
commit2b9e6416fbc87a66ae7191b367d72cfa5e9a4919 (patch)
tree79f09cdbf70abe1f0a0b6ac3798f285cd335a834 /print
parent06a56ff7bf5200556304c077c8a324b6f2e963c8 (diff)
downloadfreebsd-ports-gnome-2b9e6416fbc87a66ae7191b367d72cfa5e9a4919.tar.gz
freebsd-ports-gnome-2b9e6416fbc87a66ae7191b367d72cfa5e9a4919.tar.zst
freebsd-ports-gnome-2b9e6416fbc87a66ae7191b367d72cfa5e9a4919.zip
Add latex-subfig 1.1.20040112,
This is a LaTeX package that supports the inclusion of small "sub" figures and tables. It simplifies the positioning, captioning and labeling of them within a single figure or table environment. PR: ports/61894 Submitted by: hrs@FreeBSD.org
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-subfig/Makefile57
-rw-r--r--print/latex-subfig/distinfo1
-rw-r--r--print/latex-subfig/pkg-descr12
-rw-r--r--print/latex-subfig/pkg-plist16
5 files changed, 87 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index aaca996a39fc..01f436ffb3db 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -97,6 +97,7 @@
SUBDIR += latex-keystroke
SUBDIR += latex-mathabx
SUBDIR += latex-pgf
+ SUBDIR += latex-subfig
SUBDIR += latex-xcolor
SUBDIR += latex2rtf
SUBDIR += latex2slides
diff --git a/print/latex-subfig/Makefile b/print/latex-subfig/Makefile
new file mode 100644
index 000000000000..44de45b9762d
--- /dev/null
+++ b/print/latex-subfig/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: latex-subfig
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-subfig
+PORTVERSION= 1.1.20040112
+CATEGORIES= print
+MASTER_SITES= http://www-2.cs.cmu.edu/afs/cs/usr/sdc/www/latex/
+DISTNAME= subfig.11
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package that supports small "sub" figures/tables
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= ${STY_CAPTION}:${PORTSDIR}/print/latex-caption
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+USE_GMAKE= YES
+ALL_TARGET= sty
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+STY_CAPTION= ${LOCALBASE}/${TEXMFLOCAL}/tex/latex/caption/caption.sty
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= subfig.dtx
+CLASS_FILES+= subfig.ins
+CLASS_FILES+= subfig.sty
+CLASS_FILES+= subfig.cfg
+
+DOC_FILES= README
+DOC_FILES+= test1.tex
+DOC_FILES+= test2.tex
+DOC_FILES+= test3.tex
+DOC_FILES+= test4.tex
+DOC_FILES+= test5.tex
+DOC_FILES+= test6.tex
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ @${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-subfig/distinfo b/print/latex-subfig/distinfo
new file mode 100644
index 000000000000..53a8be76c74a
--- /dev/null
+++ b/print/latex-subfig/distinfo
@@ -0,0 +1 @@
+MD5 (subfig.11.tar.gz) = e8c20d10936fd6bf194d11f29c028ea1
diff --git a/print/latex-subfig/pkg-descr b/print/latex-subfig/pkg-descr
new file mode 100644
index 000000000000..3393771506a2
--- /dev/null
+++ b/print/latex-subfig/pkg-descr
@@ -0,0 +1,12 @@
+Subfig Style:
+
+This is a LaTeX package that supports the inclusion of small "sub" figures
+and tables. It simplifies the positioning, captioning and labeling of them
+within a single figure or table environment.
+
+The subfig package replaces the older subfigure package, but is not
+completely backward compatible with it. Therefore the name has changed to
+insure that the older package will remain around awhile, however the use of
+the older subfigure package is discouraged.
+
+WWW: http://www-2.cs.cmu.edu/afs/cs/usr/sdc/www/latex/subfigure.html
diff --git a/print/latex-subfig/pkg-plist b/print/latex-subfig/pkg-plist
new file mode 100644
index 000000000000..a44ba693f417
--- /dev/null
+++ b/print/latex-subfig/pkg-plist
@@ -0,0 +1,16 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/test1.tex
+%%PORTDOCS%%%%DOCSDIR%%/test2.tex
+%%PORTDOCS%%%%DOCSDIR%%/test3.tex
+%%PORTDOCS%%%%DOCSDIR%%/test4.tex
+%%PORTDOCS%%%%DOCSDIR%%/test5.tex
+%%PORTDOCS%%%%DOCSDIR%%/test6.tex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/subfig.dtx
+%%CLASSDIR%%/subfig.ins
+%%CLASSDIR%%/subfig.sty
+%%CLASSDIR%%/subfig.cfg
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%