aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2006-07-02 19:29:21 +0800
committermatusita <matusita@FreeBSD.org>2006-07-02 19:29:21 +0800
commit31859497fb2d3026f110b20d48d6a2356dc0d6de (patch)
tree727e17087c896a10f2c971c957c4930ab8fb4b3a /print
parente269c3b58235a07ad9ebc5be0ea14353dcd916e0 (diff)
downloadfreebsd-ports-gnome-31859497fb2d3026f110b20d48d6a2356dc0d6de.tar.gz
freebsd-ports-gnome-31859497fb2d3026f110b20d48d6a2356dc0d6de.tar.zst
freebsd-ports-gnome-31859497fb2d3026f110b20d48d6a2356dc0d6de.zip
Fix a bug that dvipdfmx confuses 'wh' and 'bk' of tpic special.
As you know from Obtained from: line below, this fix is already in the original dvipdfmx code. Submitted by: Tsuyoshi Ito, tsuyoshiito at nifty dotcom. Obtained from: http://cvs.ktug.or.kr/viewcvs/dvipdfmx/src/spc_tpic.c.diff?r2=1.3&r1=1.2&diff_format=u
Diffstat (limited to 'print')
-rw-r--r--print/dvipdfmx/Makefile2
-rw-r--r--print/dvipdfmx/files/patch-src-spc_tpic.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/print/dvipdfmx/Makefile b/print/dvipdfmx/Makefile
index f70cf52988cf..3d53e5df0b34 100644
--- a/print/dvipdfmx/Makefile
+++ b/print/dvipdfmx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvipdfmx
PORTVERSION= 20050831
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= http://project.ktug.or.kr/dvipdfmx/snapshot/current/
DIST_SUBDIR= dvipdfmx
diff --git a/print/dvipdfmx/files/patch-src-spc_tpic.c b/print/dvipdfmx/files/patch-src-spc_tpic.c
new file mode 100644
index 000000000000..c5dbf408e3df
--- /dev/null
+++ b/print/dvipdfmx/files/patch-src-spc_tpic.c
@@ -0,0 +1,26 @@
+--- src/spc_tpic.c 2005/07/30 11:44:18 1.2
++++ src/spc_tpic.c 2005/10/14 04:55:00 1.3
+@@ -1,4 +1,4 @@
+-/* $Header: /home/cvsroot/dvipdfmx/src/spc_tpic.c,v 1.2 2005/07/30 11:44:18 hirata Exp $
++/* $Header: /home/cvsroot/dvipdfmx/src/spc_tpic.c,v 1.3 2005/10/14 04:55:00 chofchof Exp $
+
+ This is dvipdfmx, an eXtended version of dvipdfm by Mark A. Wicks.
+
+@@ -743,7 +743,7 @@
+ ASSERT(spe && ap && tp);
+
+ tp->fill_shape = 1;
+- tp->fill_color = 1.0;
++ tp->fill_color = 0.0;
+
+ return 0;
+ }
+@@ -757,7 +757,7 @@
+ ASSERT(spe && ap && tp);
+
+ tp->fill_shape = 1;
+- tp->fill_color = 0.0;
++ tp->fill_color = 1.0;
+
+ return 0;
+ }