aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
committerkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
commit4490d4bc75707dbdea79b297aac91b4ce174c25f (patch)
tree3fa9947d2b38c86d548ab0b4face968420a2825b /print
parent929b8a6a2120516c63b8fecd8eba713ab5aafae2 (diff)
downloadfreebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.gz
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.zst
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.zip
Convert code in bsd.port.mk for USE_GHOSTSCRIPT* to USES=ghostscript.
Add GHOSTSCRIPT_DEFAULT to bsd.default-versions.mk for easy version selection. Arguments supported: <empty>, build, run, nox11 and agpl PR: 201201 (exp-run) Approved by: portmgr (mat@) Exp run by: antione@ (previous patch) Differential Revision: https://reviews.freebsd.org/D2938
Diffstat (limited to 'print')
-rw-r--r--print/auctex/Makefile2
-rw-r--r--print/cups-filters/Makefile4
-rw-r--r--print/cups-fxlinuxprint/Makefile3
-rw-r--r--print/cups-pdf/Makefile2
-rw-r--r--print/cups-pstoraster/Makefile3
-rw-r--r--print/dvisvg/Makefile2
-rw-r--r--print/epsonepl/Makefile3
-rw-r--r--print/flpsed/Makefile3
-rw-r--r--print/font2svg/Makefile2
-rw-r--r--print/foo2zjs/Makefile3
-rw-r--r--print/foomatic-filters/Makefile3
-rw-r--r--print/ggv/Makefile5
-rw-r--r--print/ghostscript7-commfont/Makefile2
-rw-r--r--print/ghostscript7-jpnfont/Makefile2
-rw-r--r--print/ghostscript7-korfont/Makefile2
-rw-r--r--print/gspdf/Makefile3
-rw-r--r--print/gsview/Makefile3
-rw-r--r--print/gv/Makefile3
-rw-r--r--print/hpijs/Makefile3
-rw-r--r--print/hplip/Makefile4
-rw-r--r--print/html2ps/Makefile3
-rw-r--r--print/kpdftool/Makefile3
-rw-r--r--print/libspectre/Makefile3
-rw-r--r--print/lilypond-devel/Makefile4
-rw-r--r--print/lilypond/Makefile4
-rw-r--r--print/lpr-wrapper/Makefile3
-rw-r--r--print/magicfilter/Makefile2
-rw-r--r--print/ps2eps/Makefile3
-rw-r--r--print/psdim/Makefile2
-rw-r--r--print/pstotext/Makefile2
-rw-r--r--print/scribus/Makefile4
-rw-r--r--print/texlive-base/Makefile3
-rw-r--r--print/texvc/Makefile2
-rw-r--r--print/transfig/Makefile3
34 files changed, 40 insertions, 58 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index a350468aa46d..b9a8a1c1d4ae 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
NOT_FOR_ARCHS= ia64
USE_TEX= latex
-USE_GHOSTSCRIPT=yes
+USES= ghostscript
USE_EMACS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR} \
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index 54f5130810d0..ba20a2a7df96 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -23,11 +23,11 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libpoppler.so:${PORTSDIR}/graphics/poppler
MAKE_JOBS_UNSAFE=YES
-USES= compiler:c++11-lib cpe jpeg libtool pathfix pkgconfig shebangfix tar:xz
+USES= compiler:c++11-lib cpe ghostscript jpeg libtool pathfix \
+ pkgconfig shebangfix tar:xz
CPE_VENDOR= linuxfoundation
SHEBANG_FILES= filter/textonly
USE_GNOME= glib20
-USE_GHOSTSCRIPT= yes
USE_RC_SUBR= cups_browsed
GNU_CONFIGURE= yes
CUPS_SOCKET?= /var/run/cups.sock
diff --git a/print/cups-fxlinuxprint/Makefile b/print/cups-fxlinuxprint/Makefile
index 6f22e934b8b9..e22f3a53fea8 100644
--- a/print/cups-fxlinuxprint/Makefile
+++ b/print/cups-fxlinuxprint/Makefile
@@ -14,9 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
-USES= dos2unix
+USES= dos2unix ghostscript:run
DOS2UNIX_FILES= fxlinuxprint.ppd
-USE_GHOSTSCRIPT_RUN=yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/print/cups-pdf/Makefile b/print/cups-pdf/Makefile
index 9fe7617e712c..9eb375458b8c 100644
--- a/print/cups-pdf/Makefile
+++ b/print/cups-pdf/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT= DOCS
diff --git a/print/cups-pstoraster/Makefile b/print/cups-pstoraster/Makefile
index d409e10e5b89..6340ca51d9d1 100644
--- a/print/cups-pstoraster/Makefile
+++ b/print/cups-pstoraster/Makefile
@@ -23,9 +23,8 @@ WRKSRC= ${WRKDIR}/espgs-${PORTVERSION}
DATADIR= ${PREFIX}/share/espgs
-USES= gmake iconv tar:bzip2
# We just need the ghostscript fonts, nothing more
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run gmake iconv tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/print/dvisvg/Makefile b/print/dvisvg/Makefile
index d780cf0786f2..d43ed28c3775 100644
--- a/print/dvisvg/Makefile
+++ b/print/dvisvg/Makefile
@@ -13,7 +13,7 @@ COMMENT= Converter from DVI to SVG
LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run
USE_TEX= base texmf texhash
ALL_TARGET= # empty
# workaround for svgfonts.c not including kpathsea/c-auto.h
diff --git a/print/epsonepl/Makefile b/print/epsonepl/Makefile
index 97f9a33e8772..3b368dc71627 100644
--- a/print/epsonepl/Makefile
+++ b/print/epsonepl/Makefile
@@ -13,8 +13,7 @@ COMMENT= Printer filter for EPSON EPL-5700L etc
LIB_DEPENDS= libijs.so:${PORTSDIR}/print/libijs
-USES= uidfix tar:tgz
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run uidfix tar:tgz
MAKEFILE= ${FILESDIR}/Makefile
SUB_FILES= pkg-message
diff --git a/print/flpsed/Makefile b/print/flpsed/Makefile
index 88d8dcd46a96..88f1b1b4577e 100644
--- a/print/flpsed/Makefile
+++ b/print/flpsed/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv3
LIB_DEPENDS+= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
-USE_GHOSTSCRIPT=yes
-USES= desktop-file-utils gmake
+USES= desktop-file-utils ghostscript gmake
PLIST_FILES= bin/flpsed \
man/man1/flpsed.1.gz \
share/applications/flpsed.desktop \
diff --git a/print/font2svg/Makefile b/print/font2svg/Makefile
index 7b60078e39e6..a28fe4ecc13d 100644
--- a/print/font2svg/Makefile
+++ b/print/font2svg/Makefile
@@ -12,7 +12,7 @@ COMMENT= All font to svg-font converter
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run
NO_BUILD= yes
PLIST_FILES= bin/font2svg %%DATADIR%%/encodings %%DATADIR%%/font2svg.ps
diff --git a/print/foo2zjs/Makefile b/print/foo2zjs/Makefile
index e15f03d81bfa..37e57bb83843 100644
--- a/print/foo2zjs/Makefile
+++ b/print/foo2zjs/Makefile
@@ -17,8 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/foomatic/db/oldprinterids:${PORTSDIR}/print/foom
gsed:${PORTSDIR}/textproc/gsed
PROJECTHOST= bsdistfiles
-USE_GHOSTSCRIPT=yes
-USES= gmake shebangfix
+USES= ghostscript gmake shebangfix
SHEBANG_FILES= msexpand
SUB_FILES= pkg-message ${DEVDCONF_FILE}
EXTRAFILES= msexpand getweb
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index 993e25afc324..0b25a7b04309 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -15,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
-USES= autoreconf perl5 pkgconfig
-USE_GHOSTSCRIPT=yes
+USES= autoreconf ghostscript perl5 pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
ac_cv_path_CUPS=${LOCALBASE}/libexec/cups \
diff --git a/print/ggv/Makefile b/print/ggv/Makefile
index 5a519bd39985..6557b2b443c9 100644
--- a/print/ggv/Makefile
+++ b/print/ggv/Makefile
@@ -14,9 +14,8 @@ COMMENT= GNOME 2 ghostscript viewer
INSTALLS_OMF= yes
USE_GNOME= gnomeprefix intlhack libgnomeui
-USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- tar:bzip2
-USE_GHOSTSCRIPT=yes
+USES= desktop-file-utils gettext ghostscript gmake libtool \
+ pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lm
diff --git a/print/ghostscript7-commfont/Makefile b/print/ghostscript7-commfont/Makefile
index 63f88ddeca4f..92d464c4d075 100644
--- a/print/ghostscript7-commfont/Makefile
+++ b/print/ghostscript7-commfont/Makefile
@@ -23,7 +23,7 @@ PLIST_SUB= GS_RESDIR="${GS_RESDIR}"
PKGMESSAGE= ${WRKDIR}/pkg-message
DEPENDS_ARGS+= -DA4
# set these forcibly
-USE_GHOSTSCRIPT_RUN=7
+USES= ghostscript:7,run
CONFLICTS_INSTALL= \
ghostscript8-[0-9]* \
diff --git a/print/ghostscript7-jpnfont/Makefile b/print/ghostscript7-jpnfont/Makefile
index 5008cf40c039..cc2fd0e5cecb 100644
--- a/print/ghostscript7-jpnfont/Makefile
+++ b/print/ghostscript7-jpnfont/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/std.ja_JP/Ryumin-Light.gs7:${PORTSDIR}/jap
${LOCALBASE}/share/ghostscript/Resource/CIDFont/Ryumin-Light:${PORTSDIR}/print/ghostscript7-commfont
# set these forcibly
-USE_GHOSTSCRIPT_RUN= 7
+USES= ghostscript:7,run
NO_BUILD= yes
DEPENDS_ARGS+= -DA4
diff --git a/print/ghostscript7-korfont/Makefile b/print/ghostscript7-korfont/Makefile
index 6a3751cb5413..739d0614c8d3 100644
--- a/print/ghostscript7-korfont/Makefile
+++ b/print/ghostscript7-korfont/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/CIDFont/Munhwa-Regular:${PORTSDIR}/korean/
${LOCALBASE}/share/ghostscript/Resource/CIDFont/HYSMyeongJo-Medium:${PORTSDIR}/print/ghostscript7-commfont
# set these forcibly
-USE_GHOSTSCRIPT_RUN= 7
+USES= ghostscript:7,run
NO_BUILD= yes
DEPENDS_ARGS+= -DA4
diff --git a/print/gspdf/Makefile b/print/gspdf/Makefile
index 3b6b6959b6b6..86ab8bd9c50b 100644
--- a/print/gspdf/Makefile
+++ b/print/gspdf/Makefile
@@ -10,9 +10,8 @@ DISTNAME= GSPdf-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Postscript and Pdf Viewer for GNUstep
-USES= gnustep
+USES= ghostscript gnustep
USE_GNUSTEP= back build
-USE_GHOSTSCRIPT= yes
MAKE_ENV= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
diff --git a/print/gsview/Makefile b/print/gsview/Makefile
index 07a3bc50d4bb..5d2e8582209d 100644
--- a/print/gsview/Makefile
+++ b/print/gsview/Makefile
@@ -18,9 +18,8 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
RUN_DEPENDS+= epstool:${PORTSDIR}/graphics/epstool \
pstotext:${PORTSDIR}/print/pstotext
-USES= cpe
+USES= cpe ghostscript
USE_GNOME= gtk12
-USE_GHOSTSCRIPT=yes
MAKE_JOBS_UNSAFE= yes
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 81882b024f8f..45685cbdd37f 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -13,8 +13,7 @@ COMMENT= PostScript and PDF previewer
LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XORG= xpm ice sm xext xmu x11
-USE_GHOSTSCRIPT= yes
-USES= cpe iconv gmake perl5 shebangfix
+USES= cpe ghostscript iconv gmake perl5 shebangfix
USE_PERL5= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index eed870e93813..21e65e8206d0 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -13,8 +13,7 @@ CONFLICTS= hplip-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking
-USES= jpeg
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run jpeg
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 80efd33160bc..792ee66265ad 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -21,8 +21,8 @@ RUN_DEPENDS= espgs:${PORTSDIR}/print/cups-pstoraster \
CONFLICTS_INSTALL= hpijs-[0-9]*
INSTALL_TARGET= install-strip
-USES= dos2unix jpeg libtool pkgconfig python shebangfix
-USE_GHOSTSCRIPT_RUN= yes
+USES= dos2unix ghostscript:run jpeg libtool pkgconfig python \
+ shebangfix
USE_GNOME= pygobject
USE_LDCONFIG= yes
diff --git a/print/html2ps/Makefile b/print/html2ps/Makefile
index 0b915172a311..b602bd562344 100644
--- a/print/html2ps/Makefile
+++ b/print/html2ps/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= mogrify:${PORTSDIR}/graphics/ImageMagick \
paperconf:${PORTSDIR}/print/libpaper
NO_BUILD= yes
-USES= perl5
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run perl5
SUB_FILES= html2psrc
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
index da913bad4aa5..1795a8a50e31 100644
--- a/print/kpdftool/Makefile
+++ b/print/kpdftool/Makefile
@@ -14,8 +14,7 @@ COMMENT= Simple utility to manipulate PS and PDF files
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_QT4= qt3support moc_build porting_build uic3_build
-USE_GHOSTSCRIPT_RUN= yes
-USES= qmake zip
+USES= ghostscript:run qmake zip
DESKTOP_ENTRIES= "KPDFTool" "${COMMENT}" "kpdftool" \
"kpdftool" "Qt;Utility;" true
diff --git a/print/libspectre/Makefile b/print/libspectre/Makefile
index ca303796f7e8..c4c8bb82c3c9 100644
--- a/print/libspectre/Makefile
+++ b/print/libspectre/Makefile
@@ -12,10 +12,9 @@ COMMENT= Small library for rendering Postscript documents
LICENSE= GPLv2
-USES= gmake libtool:keepla pathfix pkgconfig
+USES= gmake libtool:keepla pathfix pkgconfig ghostscript
USE_LDCONFIG= yes
USE_GNOME= cairo
-USE_GHOSTSCRIPT=yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index 87c08fb115df..0ced1df48b23 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -47,9 +47,9 @@ INFO= internals \
lilypond-web \
music-glossary
-USES= bison:build gettext gmake pkgconfig perl5 compiler:c++11-lib python:-3
+USES= bison:build gettext ghostscript:9 gmake pkgconfig perl5 \
+ compiler:c++11-lib python:-3
USE_CXXSTD= c++11
-USE_GHOSTSCRIPT=9
USE_TEX= latex
USE_PERL5= build
USE_GNOME= pango
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 8d91e11d102b..184086fb0a38 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -47,8 +47,8 @@ INFO= internals \
lilypond-web \
music-glossary
-USES= bison:build gettext gmake pkgconfig perl5 python:-3
-USE_GHOSTSCRIPT=9
+USES= bison:build gettext ghostscript:9 gmake pkgconfig perl5 \
+ python:-3
USE_TEX= latex
USE_PERL5= build
USE_GNOME= pango
diff --git a/print/lpr-wrapper/Makefile b/print/lpr-wrapper/Makefile
index 059f190e41c7..04c1ee5c4c75 100644
--- a/print/lpr-wrapper/Makefile
+++ b/print/lpr-wrapper/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
mpage:${PORTSDIR}/print/mpage \
pstops:${PORTSDIR}/print/psutils
-USES= shebangfix
+USES= ghostscript:run shebangfix
SHEBANG_FILES= lpr-wrapper.in lpr-wrapper-cups.in lpr-wrapper-features
-USE_GHOSTSCRIPT_RUN= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
diff --git a/print/magicfilter/Makefile b/print/magicfilter/Makefile
index 1ec324ee0a83..4eed4f18bc19 100644
--- a/print/magicfilter/Makefile
+++ b/print/magicfilter/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.pell.portland.or.us/~orc/Code/magicfilter/
MAINTAINER= ports@FreeBSD.org
COMMENT= Customizable, extensible automatic printer filter
-USE_GHOSTSCRIPT= yes
+USES= ghostscript
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.sh
diff --git a/print/ps2eps/Makefile b/print/ps2eps/Makefile
index 4d392dfa8c77..cf437a00480c 100644
--- a/print/ps2eps/Makefile
+++ b/print/ps2eps/Makefile
@@ -13,8 +13,7 @@ COMMENT= Generate Encapsulated Postscript file from Postscript document
WRKSRC= ${WRKDIR}/ps2eps
-USE_GHOSTSCRIPT_RUN= yes
-USES= perl5
+USES= ghostscript:run perl5
USE_PERL5= run
OPTIONS_DEFINE= DOCS
diff --git a/print/psdim/Makefile b/print/psdim/Makefile
index f59d82df473f..0777c6989a35 100644
--- a/print/psdim/Makefile
+++ b/print/psdim/Makefile
@@ -12,7 +12,7 @@ COMMENT= Calculates the optimal placement of the pages for n-up printing
LICENSE= GPLv2
-USE_GHOSTSCRIPT=yes
+USES= ghostscript
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
diff --git a/print/pstotext/Makefile b/print/pstotext/Makefile
index 06387a57608c..eb3a70c95c1e 100644
--- a/print/pstotext/Makefile
+++ b/print/pstotext/Makefile
@@ -18,7 +18,7 @@ LICENSE_NAME= End User License Agreement
LICENSE_FILE= ${WRKSRC}/pstotext.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run
SUB_LIST= LICENSE=${LICENSE} \
LICENSE_DIR=${_LICENSE_DIR}
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index c910b96c8264..b95ba0a5b7d2 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -27,8 +27,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinte
USE_QT4= gui linguist_build moc_build qmake_build rcc_build uic_build xml network
USE_GNOME= libartlgpl2 libxml2
-USE_GHOSTSCRIPT_RUN= yes
-USES= cmake desktop-file-utils jpeg pkgconfig python shared-mime-info tar:xz
+USES= cmake desktop-file-utils ghostscript:run jpeg pkgconfig \
+ python shared-mime-info tar:xz
USE_LDCONFIG= yes
CMAKE_ARGS+= -DWANT_HUNSPELL=YES -Wno-ferror-limit
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index fac2c9293f11..1286b45e344f 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -29,9 +29,8 @@ LIB_DEPENDS= libicuio.so:${PORTSDIR}/devel/icu \
CONFLICTS_INSTALL= texlive-texmf-201[23]*
USE_TEX= web2c kpathsea ptexenc texhash-bootstrap
-USES= gmake pkgconfig perl5 shebangfix tar:xz
+USES= ghostscript gmake pkgconfig perl5 shebangfix tar:xz
USE_AUTOTOOLS= autoconf
-USE_GHOSTSCRIPT=yes
USE_PERL5= run
USE_LDCONFIG= yes
# during build phase gnu configure is run a lot
diff --git a/print/texvc/Makefile b/print/texvc/Makefile
index 23c91f23b87c..60c87ff30ad4 100644
--- a/print/texvc/Makefile
+++ b/print/texvc/Makefile
@@ -24,7 +24,7 @@ RASTER_DESC= rasterization support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MRASTER}
-USE_GHOSTSCRIPT_RUN= yes
+USES+= ghostscript:run
USE_TEX= latex dvipsk
RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index a66072509aa1..7eb1ca2f8d90 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -14,9 +14,8 @@ COMMENT= Tools to convert Xfig .fig files
RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-USES= alias imake
+USES= alias ghostscript:run imake
CFLAGS+= -Wno-return-type
-USE_GHOSTSCRIPT_RUN= yes
USE_XORG= xpm
MAKE_ARGS+= INSTALLFLAGS="${COPY}" \