aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2011-06-27 10:52:45 +0800
committerhrs <hrs@FreeBSD.org>2011-06-27 10:52:45 +0800
commit59f51754eaaea28ca74f80083acca70be2fe4ace (patch)
tree2a7039f6a3018ecd01886bf8952decfb459188a8 /print
parent6c546c7475adb68e599274dae5b9b183639eaa1a (diff)
downloadfreebsd-ports-gnome-59f51754eaaea28ca74f80083acca70be2fe4ace.tar.gz
freebsd-ports-gnome-59f51754eaaea28ca74f80083acca70be2fe4ace.tar.zst
freebsd-ports-gnome-59f51754eaaea28ca74f80083acca70be2fe4ace.zip
Fix build in the case that $KERNCONF has multiple configuration files.
Spotted by: Nicolas Rachinsky
Diffstat (limited to 'print')
-rw-r--r--print/acroreadwrapper/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/print/acroreadwrapper/Makefile b/print/acroreadwrapper/Makefile
index 5e8a51a96711..c8f8c35e3412 100644
--- a/print/acroreadwrapper/Makefile
+++ b/print/acroreadwrapper/Makefile
@@ -41,7 +41,12 @@ KMODDIR= libexec/linux_adobe
.include <bsd.port.pre.mk>
KERNCONF?= GENERIC
-.if !exists(${SRC_BASE}/sys/${ARCH}/conf/${KERNCONF})
+# Use the first component of ${KERNCONF}.
+.for K in ${KERNCONF}
+_KERNCONF?=$K
+.endfor
+
+.if !exists(${SRC_BASE}/sys/${ARCH}/conf/${_KERNCONF})
IGNORE= requires kernel source to be installed
.endif