aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-27 07:45:54 +0800
committermiwi <miwi@FreeBSD.org>2009-04-27 07:45:54 +0800
commit69f4f403c29f82b0254bc1aab762e9ee7eb4e1df (patch)
treedecf9613593d264311adb464f212e4f8a9bf2c28 /print
parent3a703954c0f204047b66f5361ae8758202cafcc6 (diff)
downloadfreebsd-ports-gnome-69f4f403c29f82b0254bc1aab762e9ee7eb4e1df.tar.gz
freebsd-ports-gnome-69f4f403c29f82b0254bc1aab762e9ee7eb4e1df.tar.zst
freebsd-ports-gnome-69f4f403c29f82b0254bc1aab762e9ee7eb4e1df.zip
relatorio is a templating library which provides a way to easily output
all kind of different files (odt, ods, png, svg, ...). Adding support for more filetype is easy: you just have to create a plugin for this. relatorio also provides a report repository allowing you to link python objects and report together, find reports by mimetypes/name/python objects. WWW: http://relatorio.openhex.org/ PR: ports/133958 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-relatorio/Makefile23
-rw-r--r--print/py-relatorio/distinfo3
-rw-r--r--print/py-relatorio/pkg-descr8
-rw-r--r--print/py-relatorio/pkg-plist31
5 files changed, 66 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 54aa1f187e1f..2bfecaea9682 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -288,6 +288,7 @@
SUBDIR += py-fonttools
SUBDIR += py-pdf
SUBDIR += py-pyscript
+ SUBDIR += py-relatorio
SUBDIR += py-reportlab
SUBDIR += py-reportlab2
SUBDIR += py-rtf
diff --git a/print/py-relatorio/Makefile b/print/py-relatorio/Makefile
new file mode 100644
index 000000000000..61479176bed6
--- /dev/null
+++ b/print/py-relatorio/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-relatorio
+# Date created: 23 April,2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= relatorio
+PORTVERSION= 0.5.1
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A templating library able to output odt and pdf files
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:${PORTSDIR}/textproc/py-genshi \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.2:${PORTSDIR}/devel/py-lxml
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/print/py-relatorio/distinfo b/print/py-relatorio/distinfo
new file mode 100644
index 000000000000..3f0528c913ca
--- /dev/null
+++ b/print/py-relatorio/distinfo
@@ -0,0 +1,3 @@
+MD5 (relatorio-0.5.1.tar.gz) = 5abd2c425a96c8aa72c93bb5834afbea
+SHA256 (relatorio-0.5.1.tar.gz) = f6ee39874b6dae3245b4a5a132577e77f2d860be030dc974c8b7c083e235314b
+SIZE (relatorio-0.5.1.tar.gz) = 13031
diff --git a/print/py-relatorio/pkg-descr b/print/py-relatorio/pkg-descr
new file mode 100644
index 000000000000..de9a4ab6c533
--- /dev/null
+++ b/print/py-relatorio/pkg-descr
@@ -0,0 +1,8 @@
+relatorio is a templating library which provides a way to easily output
+all kind of different files (odt, ods, png, svg, ...). Adding support
+for more filetype is easy: you just have to create a plugin for this.
+relatorio also provides a report repository allowing you to link python
+objects and report together, find reports by mimetypes/name/python
+objects.
+
+WWW: http://relatorio.openhex.org/
diff --git a/print/py-relatorio/pkg-plist b/print/py-relatorio/pkg-plist
new file mode 100644
index 000000000000..1ffa9c7bb42c
--- /dev/null
+++ b/print/py-relatorio/pkg-plist
@@ -0,0 +1,31 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/reporting.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/reporting.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/reporting.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/base.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/base.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/base.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/chart.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/chart.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/chart.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/opendocument.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/opendocument.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/opendocument.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/pdf.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/pdf.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates/pdf.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio/templates
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/relatorio
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%