aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-20 03:44:11 +0800
committerkrion <krion@FreeBSD.org>2004-03-20 03:44:11 +0800
commit76f6efa46d87d53e0cab75bf5f19335c99deefa3 (patch)
tree122b076f94c2d805016545094a2990a22edccb18 /print
parent08704245aafb5e4680cb09769b51b3b0aa0ddb6c (diff)
downloadfreebsd-ports-gnome-76f6efa46d87d53e0cab75bf5f19335c99deefa3.tar.gz
freebsd-ports-gnome-76f6efa46d87d53e0cab75bf5f19335c99deefa3.tar.zst
freebsd-ports-gnome-76f6efa46d87d53e0cab75bf5f19335c99deefa3.zip
- Fix build with freetype-2.1.7
PR: ports/64472 Submitted by: Ports Fury
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript-afpl/Makefile2
-rw-r--r--print/ghostscript-afpl/files/patch-src:fapi_ft.c12
-rw-r--r--print/ghostscript-gpl/Makefile2
-rw-r--r--print/ghostscript-gpl/files/patch-src:fapi_ft.c12
-rw-r--r--print/ghostscript8/Makefile2
-rw-r--r--print/ghostscript8/files/patch-src:fapi_ft.c12
6 files changed, 42 insertions, 0 deletions
diff --git a/print/ghostscript-afpl/Makefile b/print/ghostscript-afpl/Makefile
index 9703756aa59a..d18871480fb4 100644
--- a/print/ghostscript-afpl/Makefile
+++ b/print/ghostscript-afpl/Makefile
@@ -426,6 +426,8 @@ pre-build:
.endfor
.if defined(WITH_FT_BRIDGE)
${MKDIR} ${WRKSRC}/freetype/include
+ ${LN} -sf ${LOCALBASE}/include/ft2build.h \
+ ${WRKSRC}/freetype/include/ft2build.h
${LN} -sf ${LOCALBASE}/include/freetype2/freetype \
${WRKSRC}/freetype/include/freetype
${MKDIR} ${WRKSRC}/freetype/objs
diff --git a/print/ghostscript-afpl/files/patch-src:fapi_ft.c b/print/ghostscript-afpl/files/patch-src:fapi_ft.c
new file mode 100644
index 000000000000..9238e4f52ee8
--- /dev/null
+++ b/print/ghostscript-afpl/files/patch-src:fapi_ft.c
@@ -0,0 +1,12 @@
+--- src/fapi_ft.c.orig Sat Dec 13 07:07:59 2003
++++ src/fapi_ft.c Wed Mar 17 21:43:43 2004
+@@ -30,7 +30,8 @@
+ #include "math_.h"
+
+ /* FreeType headers */
+-#include "freetype/freetype.h"
++#include "ft2build.h"
++#include FT_FREETYPE_H
+ #include "freetype/ftincrem.h"
+ #include "freetype/ftglyph.h"
+ #include "freetype/ftoutln.h"
diff --git a/print/ghostscript-gpl/Makefile b/print/ghostscript-gpl/Makefile
index 9703756aa59a..d18871480fb4 100644
--- a/print/ghostscript-gpl/Makefile
+++ b/print/ghostscript-gpl/Makefile
@@ -426,6 +426,8 @@ pre-build:
.endfor
.if defined(WITH_FT_BRIDGE)
${MKDIR} ${WRKSRC}/freetype/include
+ ${LN} -sf ${LOCALBASE}/include/ft2build.h \
+ ${WRKSRC}/freetype/include/ft2build.h
${LN} -sf ${LOCALBASE}/include/freetype2/freetype \
${WRKSRC}/freetype/include/freetype
${MKDIR} ${WRKSRC}/freetype/objs
diff --git a/print/ghostscript-gpl/files/patch-src:fapi_ft.c b/print/ghostscript-gpl/files/patch-src:fapi_ft.c
new file mode 100644
index 000000000000..9238e4f52ee8
--- /dev/null
+++ b/print/ghostscript-gpl/files/patch-src:fapi_ft.c
@@ -0,0 +1,12 @@
+--- src/fapi_ft.c.orig Sat Dec 13 07:07:59 2003
++++ src/fapi_ft.c Wed Mar 17 21:43:43 2004
+@@ -30,7 +30,8 @@
+ #include "math_.h"
+
+ /* FreeType headers */
+-#include "freetype/freetype.h"
++#include "ft2build.h"
++#include FT_FREETYPE_H
+ #include "freetype/ftincrem.h"
+ #include "freetype/ftglyph.h"
+ #include "freetype/ftoutln.h"
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 9703756aa59a..d18871480fb4 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -426,6 +426,8 @@ pre-build:
.endfor
.if defined(WITH_FT_BRIDGE)
${MKDIR} ${WRKSRC}/freetype/include
+ ${LN} -sf ${LOCALBASE}/include/ft2build.h \
+ ${WRKSRC}/freetype/include/ft2build.h
${LN} -sf ${LOCALBASE}/include/freetype2/freetype \
${WRKSRC}/freetype/include/freetype
${MKDIR} ${WRKSRC}/freetype/objs
diff --git a/print/ghostscript8/files/patch-src:fapi_ft.c b/print/ghostscript8/files/patch-src:fapi_ft.c
new file mode 100644
index 000000000000..9238e4f52ee8
--- /dev/null
+++ b/print/ghostscript8/files/patch-src:fapi_ft.c
@@ -0,0 +1,12 @@
+--- src/fapi_ft.c.orig Sat Dec 13 07:07:59 2003
++++ src/fapi_ft.c Wed Mar 17 21:43:43 2004
+@@ -30,7 +30,8 @@
+ #include "math_.h"
+
+ /* FreeType headers */
+-#include "freetype/freetype.h"
++#include "ft2build.h"
++#include FT_FREETYPE_H
+ #include "freetype/ftincrem.h"
+ #include "freetype/ftglyph.h"
+ #include "freetype/ftoutln.h"