aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-07 20:52:11 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-07 20:52:11 +0800
commit8748189c3faf465ca8d0d1010a51cf9fecdd8105 (patch)
treea0bb9b765790883dc16e82faf66f998cc44de5b9 /print
parent1b618f8a12cb57d4fdb84d406ee2aa26cd9f0369 (diff)
downloadfreebsd-ports-gnome-8748189c3faf465ca8d0d1010a51cf9fecdd8105.tar.gz
freebsd-ports-gnome-8748189c3faf465ca8d0d1010a51cf9fecdd8105.tar.zst
freebsd-ports-gnome-8748189c3faf465ca8d0d1010a51cf9fecdd8105.zip
Stagify, use shebangfix to fix bash path.
Diffstat (limited to 'print')
-rw-r--r--print/lpr-wrapper/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/print/lpr-wrapper/Makefile b/print/lpr-wrapper/Makefile
index 0c823369386b..57d713f99995 100644
--- a/print/lpr-wrapper/Makefile
+++ b/print/lpr-wrapper/Makefile
@@ -10,23 +10,18 @@ MASTER_SITES= http://www.mathstat.dal.ca/~selinger/lpr-wrapper/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A user level printer frontend
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ ppdfilt:${PORTSDIR}/print/libppd \
+ psdim:${PORTSDIR}/print/psdim \
+ mpage:${PORTSDIR}/print/mpage \
+ pstops:${PORTSDIR}/print/psutils
+
+USES= shebangfix
+SHEBANG_FILES= lpr-wrapper.in lpr-wrapper-cups.in lpr-wrapper-features
USE_GHOSTSCRIPT_RUN= yes
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS+= ppdfilt:${PORTSDIR}/print/libppd
-RUN_DEPENDS+= psdim:${PORTSDIR}/print/psdim
-RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
-RUN_DEPENDS+= pstops:${PORTSDIR}/print/psutils
-
PLIST_FILES= bin/lpr-wrapper bin/lpr-wrapper-cups bin/lpr-wrapper-features
-NO_STAGE= yes
-post-build:
- ${REINPLACE_CMD} -e 's|#!/bin/bash|#!/usr/bin/env bash|' \
- ${WRKSRC}/lpr-wrapper ${WRKSRC}/lpr-wrapper-cups \
- ${WRKSRC}/lpr-wrapper-features
-
.include <bsd.port.mk>