aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-06-01 06:18:51 +0800
committermezz <mezz@FreeBSD.org>2006-06-01 06:18:51 +0800
commitaff7f008477de74dded8211f70a9f7968f48a7a9 (patch)
tree6eb6930410f5cd4cbc14264efb3806451b9ffd8e /print
parent39f98a814a57781d33682c003ca58717d56c38af (diff)
downloadfreebsd-ports-gnome-aff7f008477de74dded8211f70a9f7968f48a7a9.tar.gz
freebsd-ports-gnome-aff7f008477de74dded8211f70a9f7968f48a7a9.tar.zst
freebsd-ports-gnome-aff7f008477de74dded8211f70a9f7968f48a7a9.zip
- Add header in these *-reference ports.
- Fix a few of pkg-descr by chase the rename. - Move all PORTREVISION and PORTEPOCH to top with ?=. - Put USE_X_PREFIX back in, but under REFERENCE_PORT, and remove PREFIX? and USE_XLIB. This fix ports to use the correct mtree when you change the prefix, for example: Incorrect: (Without USE_X_PREFIX) ================================ # cd /usr/ports/x11-toolkits/gtk20 # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.local.dist <-- Here... ================================ Correct: (With USE_X_PREFIX) ================================ # cd /usr/ports/x11-toolkits/gtk20 # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.x11-4.dist <-- Here... ================================ - Change a several of *-reference ports to install in LOCALBASE instead X11BASE, but only two gtkmm*-reference couldn't be change at the moment. Bump the PORTREVISION for change prefix. Discussed with: marcus
Diffstat (limited to 'print')
-rw-r--r--print/libgnomeprint-reference/Makefile7
-rw-r--r--print/libgnomeprint/Makefile6
2 files changed, 9 insertions, 4 deletions
diff --git a/print/libgnomeprint-reference/Makefile b/print/libgnomeprint-reference/Makefile
index c1f89f7b59bd..71b657e80917 100644
--- a/print/libgnomeprint-reference/Makefile
+++ b/print/libgnomeprint-reference/Makefile
@@ -1,4 +1,11 @@
+# New ports collection makefile for: libgnomeprint-reference
+# Date created: 09 May 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
# $FreeBSD$
+#
+
+PORTREVISION= 1
REFERENCE_SRC= ${WRKSRC}/doc/reference
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 3a4fe6507104..8c0614d8d86d 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libgnomeprint
PORTVERSION= 2.12.1
+PORTREVISION?= 2
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
@@ -17,21 +18,18 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Gnome print support library
USE_BZIP2= yes
-PREFIX?= ${X11BASE}
.if !defined(REFERENCE_PORT)
-PORTREVISION= 2
-
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
popt.0:${PORTSDIR}/devel/popt
USE_BISON= yes
-USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier glib20 pango libxml2 \
libartlgpl2 ltverhack
USE_GETTEXT= yes
+USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \