aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-09-02 21:26:34 +0800
committertijl <tijl@FreeBSD.org>2013-09-02 21:26:34 +0800
commitca2a2263a744b7c6f6f551ba68906f43afe04522 (patch)
tree724d013a376d218986fefc586ed681b8c219eeb7 /print
parentd44d174b995274dd9e8ddc49b959e3790c47ce71 (diff)
downloadfreebsd-ports-gnome-ca2a2263a744b7c6f6f551ba68906f43afe04522.tar.gz
freebsd-ports-gnome-ca2a2263a744b7c6f6f551ba68906f43afe04522.tar.zst
freebsd-ports-gnome-ca2a2263a744b7c6f6f551ba68906f43afe04522.zip
Two imake related changes:
1) Move -a from XMKMF command variable to a new XMKMF_ARGS variable. For ports that don't need -a introduce USES=imake:notall. This way ports no longer have to redefine XMKMF. 2) xmkmf -a runs imake with the flags in IMAKECPPFLAGS as extra arguments to set CPP, CC and CXX. This creates the top Makefile, and then xmkmf runs make Makefiles. This Makefiles target runs imake for each subdirectory but these imake invocations did not have the flags from IMAKECPPFLAGS so the resulting makefiles used the wrong C preprocessor when clang is used (/usr/bin/cpp instead of /usr/local/bin/tradcpp). Instead of letting xmkmf pass IMAKECPPFLAGS from the environment to imake let imake handle IMAKECPPFLAGS itself just like it handles IMAKEINCLUDE. This exposed configure errors in x11-clocks/mouseclock and x11-wm/fvwm. Approved by: portmgr (bapt)
Diffstat (limited to 'print')
-rw-r--r--print/xdvi/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/print/xdvi/Makefile b/print/xdvi/Makefile
index 765f96855166..31bce59d110b 100644
--- a/print/xdvi/Makefile
+++ b/print/xdvi/Makefile
@@ -16,12 +16,11 @@ COMMENT= DVI previewer for the X Window System
CONFLICTS= teTeX-*
-USES= gmake imake
+USES= gmake imake:notall
USE_XORG= ice sm x11 xaw xext xmu xt xpm
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PLIST_SUB= LOCALBASE=${LOCALBASE}
-XMKMF= xmkmf
.if defined(PACKAGE_BUILDING)
SCRIPTS_ENV= PACKAGE_BUILDING=${PACKAGE_BUILDING}
.else